Bug 5197 - pwdb header files break usermode
pwdb header files break usermode
Status: CLOSED NEXTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: usermode (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-17 16:34 EDT by Nalin Dahyabhai
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-20 10:39:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 1999-09-17 16:34:35 EDT
Including the pwdb_public.h header in userhelper.c lets it
#define getlogin() to pwdb_posix_getlogin() (and similar
things with getpw* and getgr*), which breaks that wonderful
"can shut down as non-root user" function that showed up in
6.0, but hasn't gone away in Rawhide.
Comment 1 Michael K. Johnson 1999-09-19 21:18:59 EDT
pwdb_public.h has always, since the first version, been
included in userhelper.c...

Furthermore, I just tested shutdown -r now as a normal user
and it worked fine.  So something else is wrong, or there
was some transient bug in an earlier RawHide that is now
fixed.
Comment 2 Michael K. Johnson 1999-09-20 09:57:59 EDT
As pointed out by Nalin in private email, *using hesiod or ldap or
other authentication services that pam supports but pwdb does not,*
the wrapper functions break.

pwdb will be changed not to define those functions, and we'll
rebuild usermode, and then things should work correctly.  So this
is really a bug in pwdb, but we'll keep it filed against usermode
because usermode needs to be rebuilt after pwdb is changed before
the problem goes away.

In the long term, pwdb is just going to disappear.  Improvements
in nss have rendered it redundant.
Comment 3 Michael K. Johnson 1999-09-20 10:39:59 EDT
This will be fixed in usermode-1.12 and later, which will appear
in the next RawHide and in Red Hat Linux 6.1.

Note You need to log in before you can comment on or make changes to this bug.