Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 519725 - Exception in writeYaboot 'LVMLogicalVolumeDevice' object has no attribute 'partedPartition'
Summary: Exception in writeYaboot 'LVMLogicalVolumeDevice' object has no attribute 'pa...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: ppc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:51e3ebaa384d23e10...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 15:03 UTC by Martin Banas
Modified: 2009-09-04 14:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-04 14:29:05 UTC
Type: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (196.67 KB, text/plain)
2009-08-27 15:03 UTC, Martin Banas
no flags Details

Description Martin Banas 2009-08-27 15:03:50 UTC
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/booty/ppc.py", line 68, in writeYaboot
    f.write("partition=%s\n" % bootDev.partedPartition.number)
  File "/usr/lib/anaconda/booty/ppc.py", line 168, in write
    chainList, defaultDev, justConfig)
  File "/usr/lib/anaconda/bootloader.py", line 204, in writeBootloader
    justConfigFile)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1360, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'LVMLogicalVolumeDevice' object has no attribute 'partedPartition'

Comment 1 Martin Banas 2009-08-27 15:03:56 UTC
Created attachment 358888 [details]
Attached traceback automatically from anaconda.

Comment 2 Martin Banas 2009-08-27 15:17:00 UTC
Version of components:

Fedora 11


Steps to reproduce:

1. Run instalation of fedora 11 on PPC machine (bug found on ibm-p5-03.rhts.englab.brq.redhat.com)
2. Proceed to partitioning dialog
3. Click on create custom layout
4. On first harddrive create layout:

PXEBOOT           4MB
/boot             200MB
SWAP              4GB
Software RAID     50G
Software RAID     50G

Create RAID1 device with filesystem "physical volume (LVM)"
Create new logical volume with / mount point.

5. Click next and proceed with the instalation.


Actual result: 

anaconda throws exception when writing yaboot.

Comment 3 Joel Andres Granados 2009-09-02 10:43:14 UTC
Can you pls test with current rawhide.  The newest anaconda version is 12-18 (I think)

Comment 4 Martin Banas 2009-09-04 13:47:20 UTC
Retested with anaconda 12.19. With build rawhide20090903 everything seems to be OK.


Note You need to log in before you can comment on or make changes to this bug.