Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 519755 - Regression: Upgrade from F10 to F11 loses dual head ability
Summary: Regression: Upgrade from F10 to F11 loses dual head ability
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 11
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 17:21 UTC by Tethys
Modified: 2009-10-15 17:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-15 17:05:05 UTC
Type: ---


Attachments (Terms of Use)
xorg log file (264.08 KB, text/plain)
2009-08-27 17:21 UTC, Tethys
no flags Details
xorg.conf (3.13 KB, text/plain)
2009-08-27 17:22 UTC, Tethys
no flags Details

Description Tethys 2009-08-27 17:21:20 UTC
Created attachment 358926 [details]
xorg log file

Description of problem:
I upgraded from F10 to F11. Now I only have one screen, and it's
driving me nuts!

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.2-14.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Boot to init state 3
2. startx
3. Cringe at the lack of dual head
  
Actual results:
Same 1600x1200 image displayed on both monitors

Expected results:
Dual headed goodness (courtesy of some xrandr magic in my ~/.Xclients)

Additional info:
I don't use Xinerama. Instead, I use the following lines in ~/.Xclients:

xrandr --output VGA-0 --mode 1920x1200
xrandr --output DVI-0 --left-of VGA-0

This has worked fine up until I upgraded. Now it fails. Running the
commands manually gives:

mrburns:~% xrandr --output VGA-0 --mode 1920x1200
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  149 (RANDR)
  Minor opcode of failed request:  21 (RRSetCrtcConfig)
  Serial number of failed request:  24
  Current serial number in output stream:  24

Yet xrandr is aware that the monitor is capable of 1920x1200:

mrburns:~% xrandr 
Screen 0: minimum 320 x 200, current 1600 x 1200, maximum 3520 x 1200
VGA-0 connected 1600x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1600x1200      60.0*+
   1920x1200      60.0 +   85.0  
   2048x1200      81.2  
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.0     60.0  
   800x600        75.0     60.3  
   640x480        75.0     59.9  
   720x400        70.1  
DVI-0 connected 1600x1200+0+0 (normal left inverted right x axis y axis) 408mm x 306mm
   1600x1200      60.0*+
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  
   720x400        70.1  

My hardware details are at:

http://www.smolts.org/client/show/pub_2a97004e-5c74-42f5-9952-9058b621ba90

Comment 1 Tethys 2009-08-27 17:22:46 UTC
Created attachment 358927 [details]
xorg.conf

This is my xorg.conf from F10, which worked perfectly on the same hardware
(or at least, it gave me the ability to futz around with xrandr to get a
working dual-headed system)

Comment 2 Tethys 2009-08-27 17:23:41 UTC
FWIW, system-config-display is useless, and can't see a second video card,
so won't let me configure dual-head.

Comment 3 Tethys 2009-08-27 17:31:13 UTC
Just for completeness, I also get the same results if I try without
using an xorg.conf at all.

Comment 4 Jérôme Glisse 2009-10-15 14:57:37 UTC
Do you still have this issue with fedora 12 (you can test livecd from http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/) ?

Comment 5 Tethys 2009-10-15 15:06:27 UTC
No idea. I couldn't live with only one screen, and this bug was
getting no attention, so I had to swap out video cards until I
got something that worked. Thus I don't have the same hardware
any more, and don't have the problem any more.

Comment 6 Jérôme Glisse 2009-10-15 17:05:05 UTC
Ok so clausing this bug reopen if you experience same issue with radeon hw with fedora 12.


Note You need to log in before you can comment on or make changes to this bug.