Bug 519786 - vm.sh ignores path / drops xm --path support
Summary: vm.sh ignores path / drops xm --path support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager
Version: 5.4
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 499522 524213
TreeView+ depends on / blocked
 
Reported: 2009-08-27 19:18 UTC by Lon Hohberger
Modified: 2018-11-14 20:31 UTC (History)
10 users (show)

Fixed In Version: rgmanager-2.0.52-1.9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-30 08:47:01 UTC


Attachments (Terms of Use)
Patched vm.sh (18.08 KB, application/x-sh)
2009-08-27 19:18 UTC, Lon Hohberger
no flags Details
Patch (1.24 KB, patch)
2009-08-27 19:19 UTC, Lon Hohberger
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0280 normal SHIPPED_LIVE rgmanager bug fix and enhancement update 2010-03-29 13:59:11 UTC

Description Lon Hohberger 2009-08-27 19:18:08 UTC
Created attachment 358947 [details]
Patched vm.sh

Description of problem:

Users utilizing rgmanager to manage virtual machine locations who place their Xen domain configurations in alternate locations will have issues creating Xen virtual machines.

This is because the path attribute was erroneously removed from the resource agent metadata.

When the appropriate metadata is added back, the vm.sh agent works as expected.

Version-Release number of selected component (if applicable): rgmanager-2.0.52-1.el5

How reproducible: 100%

Steps to Reproduce:
1. Create a Xen domain
2. Move config file to a place other than /etc/xen
3. Create a clustered VM with path="/your/nonstandard/path"
4. Try to start virtual machine
  
Actual results: Rgmanager can not find the configuration file

Expected results: VM started

Comment 1 Lon Hohberger 2009-08-27 19:19:22 UTC
Created attachment 358949 [details]
Patch

Comment 2 Lon Hohberger 2009-08-27 19:20:47 UTC
Workarounds:

(a) Apply above patch or use attached vm.sh
(b) Store all Xen domain configurations in /etc/xen
(c) Symlink all Xen domain configurations in to /etc/xen

Comment 10 Chris Ward 2010-02-11 10:13:14 UTC
~~ Attention Customers and Partners - RHEL 5.5 Beta is now available on RHN ~~

RHEL 5.5 Beta has been released! There should be a fix present in this 
release that addresses your request. Please test and report back results 
here, by March 3rd 2010 (2010-03-03) or sooner.

Upon successful verification of this request, post your results and update 
the Verified field in Bugzilla with the appropriate value.

If you encounter any issues while testing, please describe them and set 
this bug into NEED_INFO. If you encounter new defects or have additional 
patch(es) to request for inclusion, please clone this bug per each request
and escalate through your support representative.

Comment 12 errata-xmlrpc 2010-03-30 08:47:01 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0280.html


Note You need to log in before you can comment on or make changes to this bug.