Bug 51994 - psql wont start. Error is psql: undefined symbol: PQgetssl
psql wont start. Error is psql: undefined symbol: PQgetssl
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: postgresql (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-17 17:11 EDT by Need Real Name
Modified: 2009-08-24 17:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-20 16:35:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-17 17:11:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
psql crashes with "psql: undefined symbol: PQgetssl" when I try to invoke 
psql in interactive mode. the "psql -e template1 < /tmp/filename" command 
runs to completion though.

Also, the rh-pgdump.sh doesn't find the binaries from the pervious 
version. The /usr/lib/opgsql/backup directory referenced in the script 
doesn't exist after 7.1 -> roswell upgrade.

The error occurs even with a fresh install, ie, not restoring the old 
database. I can create databases as user postgres, but once I try to 
connect, I get the library error

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install old postgresql and start to do a pg_dumpall
2. run pg_dumpall > /tmp/filename
3. Mv /var/lib/pgsql/data to data.bak
4. Install new postgresql and start
5. run the psql -e template1 < /tmp/filename
6. Attempt to connect to database created from the dump.
7. Cannot connect to any database.
	

Additional info:
Comment 1 Trond Eivind Glomsrxd 2001-08-17 17:16:19 EDT
rpm -q postgresql  - this doesn't happen in standard use for me, and seems to
indicate there is a mismatch of ssl-support in database and client.
Comment 2 Need Real Name 2001-08-17 23:21:36 EDT
postgresql-7.1.2-6
postgresql-server-7.1.2-6

What provides the ssl-support?
Comment 3 Glen Foster 2001-08-20 15:22:46 EDT
We (Red Hat) should really try to fix this before next release.
Comment 4 Trond Eivind Glomsrxd 2001-08-20 16:35:44 EDT
The ssl support should be built into the database and client. Note that
rh-pgdump.sh script is intended for upgraded from Red Hat Linux 6.x only - use
"pg_dumpall" for newer releases.
Comment 5 Trond Eivind Glomsrxd 2001-08-20 19:20:09 EDT
Did that - it works just fine here, with postgresql-7.1.3-1. This shouldn't be
different in older releases, though, unless you have a mismatch between client
and server.
Comment 6 Need Real Name 2001-08-20 21:17:34 EDT
I did use the pg_dumpall to dump the database. I then used the psql -e 
template1 < dumpfile command to restore the database. This operation actually 
worked. It's afterwards, when I attempt to connect to the database is when I 
get this error. Prior to the upgrade, when I was running 7.1, I had edited the 
postgres conf file, I believe pg_hba.conf to allow remote clients to connect to 
the server(via the secure one, I forget which option that was, and the box is 
off now).

Perhaps this is where the error is.
Comment 7 Trond Eivind Glomsrxd 2001-08-20 22:18:28 EDT
I did upgrade in the way you described when I closed it, and had tested it
afterwards (the database was minimal, though - one table, six records). No
problems.
Comment 8 Need Real Name 2001-08-22 18:10:29 EDT
Still having problems.. rpm -qa | grep postgresql shows all the postgresql 
packages at version 7.1.2-6

I cleaned out the /var/lib/pgsql dir, and did an initdb as postgres. I 
restarted the database. Then, as user postgres, did a `createdb test`, followed 
by `psql test` and got the same error again. 

This box was upgraded from 7.1.  
I have a openssl-0.9.6b-3 providing /lib/libssl.so.0.9.6b(version 1)
I also have a openssl096-0.9.6-5 providing /usr/lib/libssl.so.0.9.6(version 2)

Could this be the problem?

Comment 9 Fedora Update System 2009-08-24 17:49:44 EDT
xemacs-21.5.28-10.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xemacs-21.5.28-10.fc10

Note You need to log in before you can comment on or make changes to this bug.