Bug 51996 - mpg321: Error opening libao oss driver
Summary: mpg321: Error opening libao oss driver
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mpg321 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-17 22:01 UTC by CoreDump
Modified: 2014-03-17 02:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 06:42:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description CoreDump 2001-08-17 22:01:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
mpg123 (v 0.59q) has some problem when used concurrently with an X
environment with audio enabled.
The previous version (from the package mpg123) had no such problem, but it
didn't use the libao package either.

This new version doesn't display mp3 tags either when playing a .mp3 file.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start enlightenment
2. enable sound or produce an event which generates a sound
3. start mpg123
4. starting it again will make it work, but now enlightenment will be
stripped of sounds	

Actual Results:  Directory: ./
Playing MPEG stream from 01-APOCALYPTICA-Path.mp3 ...
MPEG 1.0 layer III, 192 kbit/s, 44100 Hz stereo
Error opening libao oss driver.


Expected Results:  The previous version was able to play music concurrently
with the X sounds.

The previous version displayed mp3 tags.


Additional info:

Comment 1 Joe Drew 2001-08-27 23:02:58 UTC
This is because esd has the sound driver open. The next version of mpg321
(0.2.0) will enable compile-time default sound drivers; I suggest Red Hat uses
--with-default-audio=esd when configuring mpg321 0.2.0.

Comment 2 Joe Drew 2001-09-23 15:28:47 UTC
mpg321 0.2.0 is now released.

Comment 3 Bill Nottingham 2002-01-29 03:04:53 UTC
0.2.3 will be in the next rawhide, with the configure change mentioned - thanks!


Note You need to log in before you can comment on or make changes to this bug.