Bug 51997 - kde really wants to use courier fonts
kde really wants to use courier fonts
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
roswell
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-17 19:01 EDT by eeeg
Modified: 2009-08-24 17:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-17 20:13:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eeeg 2001-08-17 19:01:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
The first time a user starts kde the fonts are nice.  After logging out of
kde and restarting X all the fonts are courier.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.add a new user to your system
2.login as that user
3.start kde.
4.click 'next' for all that 'customize' your desktop stuff.
5.when kde has finished loading observe the nice fonts.
6.logout of kde.
7.restart kde
8.observe the ugly courier that has taken over.
	

Actual Results:  i observed the ugly courier

Expected Results:  don't go changing fonts unless the user has configured
it that way

Additional info:

i just updated kde rpm's with the latest from rawhide and still had this
problem.
Comment 1 eeeg 2001-08-17 20:13:54 EDT
Ahhh, I just noticed something....

In step 4, I incorrectly wrote just click next all the way through.  On one of 
the screens it asks you something about how many 'bells and whistles' do you 
want KDE to have.  There is a little slider on the screen.  I had been 
dragging this to the max.  Doing so causes this problem.  If you don't do 
that, and accept the default, courier font is not thrust upon you.
Comment 2 Bernhard Rosenkraenzer 2001-08-18 06:49:31 EDT
This is because bitmapped fonts (e.g. Helvetica, Times) can't be antialiased, 
and the hightest Eye-Candy setting enables anti-aliasing.
You need to have suitable fonts for this to work:
Install the urw-fonts and ttfonts packages
Update qt to 2.3.1-3 (rawhide)
and it'll work.
Comment 3 Fedora Update System 2009-08-24 17:49:51 EDT
xemacs-21.5.28-10.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xemacs-21.5.28-10.fc10

Note You need to log in before you can comment on or make changes to this bug.