Bug 51999 - 3c509 network card module broken in kernel
3c509 network card module broken in kernel
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-08-17 20:05 EDT by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-17 20:05:53 EDT
Description of Problem:

3c509 network card installs, but does not work with 2.4.x kernel

Version-Release number of selected component (if applicable):

How Reproducible:
Every time

Steps to Reproduce:
1.  Install 7.1
2.  3c509 network card is recognized and installed
3.  Ethernet TCP/IP networking will not work
4.  I installed 7.1 with 2.4.x kernel, then installed 2.2.x kernel from RH
7.0, booted from older kernal using LILO, TCP/IP worked just fine.

5.  ****Please don't blow this off as the previously reported problem with
3c509, because it is not.  I have Plug n' Play turned off for the card and
in BIOS, etc.  This is a kernel problem that should be fixed.  Even though
the 3c509 is an older ISA card, there are a bunch of them in use.****

Actual Results:

Expected Results:

Additional Information:
Comment 1 lucb 2001-08-20 16:10:58 EDT
I am also having this problem.  Pnp is turned off on the card.  I upgraded from a working version of RedHat 7.0 
RedHat 7.1, now my network card no longer works.  I also have a server with two 3c509 cards in it that I want 
upgrade to RedHat 7.1.   Please advise on any workarounds ASAP.
Comment 2 lucb 2001-08-28 10:49:34 EDT
I think this problem may relate to the order in which modules are loaded.  When 
I put the 3c509 back into the system and get modules.conf to load it and then 
do a cat /proc/interrupts I notice that other cards get IRQ 12 assigned to 
them.  This is the IRQ that I manually assigned to the 3c509 and worked fine 
with RedHat 7.0.  My guess is that there are some changes in the way that 
isapnp loads and grabs IRQ for each module.  It seems that the non-PNP cards 
are loaded last.  I will attempt to convert my RH6.2 system to RH7.1 since 
their are no PNP cards in that machine and two 3c509 cards.
Comment 3 Bugzilla owner 2004-09-30 11:39:07 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.