Bug 519999 - "Work Offline" Behaviour Lacks Intelligence
Summary: "Work Offline" Behaviour Lacks Intelligence
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 22:35 UTC by David Le Sage
Modified: 2009-08-28 00:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-27 23:12:20 UTC


Attachments (Terms of Use)

Description David Le Sage 2009-08-27 22:35:10 UTC
Description of problem:
Firefox defaults to "work offline" mode every time the user logs in and starts the browser.  I suspect that this is due to the fact that the user does not have a high speed network connection and, instead, relies on dial-up modem technology.

Firefox needs more intelligence.  If the user has dialled-in with, say, kppp, Firefox should be aware that the system is currently online.


Version-Release number of selected component (if applicable):
3.5.2

How reproducible:
Every time.

Steps to Reproduce:
1. Install Fedora 11. Ensure kppp is included in installation. Configure system via Anaconda during the install process so that there is NO network connection.
2. After system is installed and configured, log in as normal user.
3. Dial your ISP with kppp.
4. Launch Firefox.
5. Note that "File->Work Offline" is always activated.
6.  Even if the user "unticks" this option, exits Firefox, turns off kppp and exits GNOME, the next time the user logs in, starts kppp and activates Firefox, it will default back to "Work Offline" mode.
  
Actual results:
Always defaults to "Work Offline", even if user is currently connected to the internet.  


Expected results:
If user is connected to the internet via kppp or another dial-up tool, Firefox should default to online mode, just as it always opens in online mode if the user has an ethernet connection. 


Additional info:
I am sure that there must be a way to over-ride this behaviour in about:config but I feel that better integration between kppp (or other dial-up tools) and Firefox would be a cleaner solution and would please that portion of the userbase still using dial-up modem connections.

Comment 1 Christopher Aillon 2009-08-27 23:12:20 UTC
It appears that you are not using NetworkManager (is there a reason you don't?  It handles dialup as well...).

Firefox uses NetworkManager to ask whether you are online, and to NM it appears you aren't since you are not using it to manage your network.  It is expected that if NetworkManager is running, it is being used to manage connections.

You should either use NetworkManager for your connections, or disable it with:

  $ su -
  $ service NetworkManager stop
  $ chkconfig NetworkManager off

Comment 2 David Le Sage 2009-08-27 23:23:50 UTC
Chris, thanks for your rapid response.  I have always tended to use kppp, even in GNOME environments as, for some reason, NetworkManager would not pick up my modem, which was mapped to /dev/ttyUSB0.  


Not sure why, as device drivers are obviously present if the KDE app can use it without any problems.


I haven't tried it for quite a few releases though, so it is probably worth investigating again.  If it does not work, I will switch that service off, as you suggest.


Would it still be worthwhile adding the extra intelligence so that Firefox is also "more aware" of kppp, particularly for KDE users?


Cheers,

David
RED HAT ASIA-PACIFIC

Comment 3 Christopher Aillon 2009-08-28 00:18:33 UTC
A lot of work recently has gone into NetworkManager specifically for dial up modems, with the creation of ModemManager (although I just realized ModemManager is only available in the rawhide/F12 alpha repositories at this time so you may wish to look into that as well).

Making apps such as Firefox aware of multiple things is a maintenance nightmare.  I think a more worthwhile goal is to get the functionality of kppp into NetworkManager/ModemManager (if it isn't yet there) as NetworkManager implements a freedesktop specification that many applications for both KDE and GNOME already use.

Comment 4 David Le Sage 2009-08-28 00:23:42 UTC
Okay, I will definitely try NetworkManager again.  Thanks.  Putting kppp functionality into NetworkManager and making it conform to free desktop specs sounds great.


Thanks again.


Note You need to log in before you can comment on or make changes to this bug.