This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 520000 - Display corruption with vim after update to vte-0.21.4
Display corruption with vim after update to vte-0.21.4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-27 18:35 EDT by Pete Zaitcev
Modified: 2009-09-26 09:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-26 09:36:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot (48.48 KB, image/png)
2009-08-30 17:18 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Pete Zaitcev 2009-08-27 18:35:24 EDT
Description of problem:

When using vim with the gnome-terminal and scrolling, scroll fails
and the terminal becomes corrupted.

Version-Release number of selected component (if applicable):

0.21.4-1.fc12

How reproducible:

100%

Steps to Reproduce:
1. identify a document that's longer than a few screenfulls
2. vi document
3. scroll down with j
  
Actual results:

The image on the screen is corrupted

Expected results:

Image is what editor expects

Additional info:

1. This only started to happen after update -- regression
2. same thing with naked vim in gnome-terminal and vim in screen
2. xterm works (both direct and through screen)
Comment 1 Pete Zaitcev 2009-08-27 18:47:59 EDT
Weird fact: I have another workstation with identical Rawhide. If I go
over ssh there (with display going back where the corruption happens),
everything is fine - there's no corruption. The corruption only happens
with local clients. The ssh runs in the same terminal that corrupts.

So, it looks like a problem with vim or terminfo locally, but all
packages between the two computers are the same (e.g. vim-common, vte,
ncurses-base (that provides terminfo)). A mystery!
Comment 2 Behdad Esfahbod 2009-08-28 14:23:48 EDT
Did you close all open terminals and start again?  If not, an earlier version may be running.

Alternatively, run "gnome-terminal --disable-factory".  I fixed that particular scrolling bug in 0.21.4.

Also, filing bugs upstream (bugzilla.gnome.org) gets a faster response.  Thanks.
Comment 3 Pete Zaitcev 2009-08-29 14:28:08 EDT
No, you only fixed the outright crash with 0.21.4. With the "old" factory
process still running I would not be able to proceed far enough to hit
this bug. Anyway, this bug persists after a system reboot, so factory
is not involved.
Comment 4 Pete Zaitcev 2009-08-29 14:38:01 EDT
I have two Rawhide systems that I use for work: desktop and laptop.
On desktop, the bug does not occur. On laptop it occurs.
The relevant package set is identical on both systems:

gnome-terminal-2.27.91-1.fc12.x86_64
ncurses-base-5.7-3.20090207.fc12.x86_64
vim-common-7.2.245-3.fc12.x86_64
vte-0.21.4-1.fc12.x86_64

Therefore, I suspect it's something in the Radeon driver on laptop.
The desktop uses Intel (Havendale).

I am reassigning this bug to xorg-x11-drv-ati, so that David Airlie
or someone else who hacks on Radeon could have a look at this.
It reproduces very easily.
Comment 5 Behdad Esfahbod 2009-08-30 16:43:22 EDT
Attach screenshot of corruption at least?
Comment 6 Pete Zaitcev 2009-08-30 17:18:13 EDT
Created attachment 359206 [details]
Screenshot

Surprise -- it can be captured by system means, without a camera.
This is taken after opening a file and hitting 'j' a few times.
Look at the bottommost line, where the cursor is.
Comment 7 Saikat Guha 2009-08-31 23:39:22 EDT
Duplicate of bug 520225 perhaps?
Comment 8 Saikat Guha 2009-09-02 16:05:18 EDT
1) I am facing the same bug (I think), but on non-ATI hardware. (on Intel i915)

2) This may be a gnome-terminal problem rather than vte.
  gnome-terminal-2.26.2-3.fc12.x86_64
  vte-0.21.4-1.fc12.x86_64
works for me.
  gnome-terminal-2.27.91-1.fc12.x86_64
  vte-0.21.4-1.fc12.x86_64
does not.
Comment 9 Pete Zaitcev 2009-09-12 23:55:07 EDT
Great, after an update the previously immune box has it too. And you know
what, the vte was not updated, but gnome-terminal was.

gnome-terminal-2.26.2-3 -- not affected for certain
gnome-terminal-2.27.91-1 -- NOT affected for me
gnome-terminal-2.27.92-1 -- affected

So there's some contention between observations by me and Saikat, but
it seems like gnome-terminal after all. I'm changing the component.
Comment 10 Pete Zaitcev 2009-09-25 22:04:21 EDT
Now it's gone on both of affected systems. Versions:
gnome-terminal-2.27.92-1.fc12.x86_64
vte-0.21.5-1.fc12.x86_64

Should I close this? Saikat?
Comment 11 Behdad Esfahbod 2009-09-25 22:15:41 EDT
Well, you should really test with 0.22.0  or 0.22.1, but yeah, I expect it to have gone.
Comment 12 Saikat Guha 2009-09-26 08:15:22 EDT
Yes. I haven't encountered this in the latest rawhide for a week or two now. Thanks.

Note You need to log in before you can comment on or make changes to this bug.