Bug 520002 - gtk2-engines.i686 skimped upon in rawhide repositories
Summary: gtk2-engines.i686 skimped upon in rawhide repositories
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 22:39 UTC by Michal Jaegermann
Modified: 2014-03-17 03:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-28 19:20:44 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2009-08-27 22:39:10 UTC
Description of problem:

Up to and including Fedora 11 both 64 and 32 bit versions of gtk2-engines were available in x86_64 repositories.  It appears that currently 32-bit version was dropped.  There are two issues with that.
1) Something may be using it.  For example acroread from an external AdobeReader_enu-9.1.3-1.i486 package complains over and over like that:

(acroread:2509): Gtk-WARNING **: Unable to locate theme engine in
module_path: "clearlooks",

and installing gtk2-engines.i686 shuts that up even if AdobeReader_enu.i486
does not have a real dependency on this.  Something else still may turn out to be upset in a more serious way.
2) Upgrading an older installation will run into issues as there will be
no update path for a possibly installed 32-bit variant of that package.

Admittedly both issues appear to be of a "cosmetic" nature, although the second one will require some post-upgrade attention.  OTOH the dropped package does not look that big so maybe it would be worth to keep it?

Version-Release number of selected component (if applicable):
gtk2-engines-2.18.2-5.fc12

Comment 1 Matthias Clasen 2009-08-27 22:46:01 UTC
Not a gtk2-engines problem. I have no idea why it would or would not be treated as multilib.

Comment 2 Bill Nottingham 2009-08-28 15:53:06 UTC
            # gtk2-engines
            if fnmatch(dirname, '/usr/lib*/gtk-2.0/*/engines'):
                return True

I'm not seeing an obvious reason why that would stop working.

Comment 3 Michal Jaegermann 2009-08-28 16:20:24 UTC
> I'm not seeing an obvious reason why that would stop working.

Hm, maybe it did not stop.  Looking at
http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os/Packages
I see at this moment gtk2-engines-2.18.2-5.fc12.x86_64.rpm and gtk2-engines-2.18.2-5.fc12.i686.rpm.  OTOH when I tried two days ago
'yum install gtk2-engines.i686' I got "No match" (or something of that sort) in a response.  I did install that package after fetching it from koji. I will try again with yum and will see what that will bring.

Comment 4 Michal Jaegermann 2009-08-28 19:20:44 UTC
I tried again 'yum install gtk2-engines.i686' and this time this worked
(mirrors.cat.pdx.edu was picked up by yum).  So apparently this was a knot
in repos.


Note You need to log in before you can comment on or make changes to this bug.