Bug 520027 - file conflicts with openmpi
Summary: file conflicts with openmpi
Keywords:
Status: CLOSED DUPLICATE of bug 496131
Alias: None
Product: Fedora
Classification: Fedora
Component: libotf
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Neal Becker
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 04:13 UTC by Alex Lancaster
Modified: 2009-08-28 04:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-28 04:30:50 UTC


Attachments (Terms of Use)

Description Alex Lancaster 2009-08-28 04:13:44 UTC
A recent emacs update that added a Requires for libotf reveals file conflicts with openmpi if you happen to have it installed.  Cc'ing openmpi maintainer, Doug Ledford.

# sudo yum update 
Loaded plugins: allowdowngrade, changelog, dellsysidplugin2, downloadonly,
              : fastestmirror, presto, priorities, protectbase, refresh-
              : packagekit, tsflags, versionlock
Loading mirror speeds from cached hostfile
 * fedora: mirrors.med.harvard.edu
 * livna: rpm.livna.org
 * rpmfusion-free: mirror.liberty.edu
 * rpmfusion-free-updates: mirror.liberty.edu
 * rpmfusion-nonfree: mirror.liberty.edu
 * rpmfusion-nonfree-updates: mirror.liberty.edu
Excluding Packages in global exclude list
Finished
0 packages excluded due to repository protections
Reading version lock configuration
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package emacs.i586 1:23.1-3.fc11 set to be updated
--> Processing Dependency: libm17n-flt.so.0 for package: 1:emacs-23.1-3.fc11.i586
--> Processing Dependency: libm17n-core.so.0 for package: 1:emacs-23.1-3.fc11.i586
--> Processing Dependency: libotf.so.0 for package: 1:emacs-23.1-3.fc11.i586
---> Package emacs-common.i586 1:23.1-3.fc11 set to be updated
---> Package emacs-el.i586 1:23.1-3.fc11 set to be updated
--> Running transaction check
---> Package libotf.i586 0:0.9.8-2.fc11 set to be updated
---> Package m17n-lib.i586 0:1.5.5-1.fc11 set to be updated
--> Processing Dependency: m17n-db >= 1.4.0 for package: m17n-lib-1.5.5-1.fc11.i586
--> Running transaction check
---> Package m17n-db.noarch 0:1.5.5-1.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package             Arch          Version                 Repository      Size
================================================================================
Updating:
 emacs               i586          1:23.1-3.fc11           updates        2.4 M
 emacs-common        i586          1:23.1-3.fc11           updates         21 M
 emacs-el            i586          1:23.1-3.fc11           updates         12 M
Installing for dependencies:
 libotf              i586          0.9.8-2.fc11            fedora          67 k
 m17n-db             noarch        1.5.5-1.fc11            updates         43 k
 m17n-lib            i586          1.5.5-1.fc11            updates        173 k

Transaction Summary
================================================================================
Install      3 Package(s)         
Update       3 Package(s)         
Remove       0 Package(s)         

Total size: 35 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/bin/otfdump from install of libotf-0.9.8-2.fc11.i586 conflicts with file from package openmpi-1.3.1-1.fc11.i586

Error Summary
-------------

Comment 1 Alex Lancaster 2009-08-28 04:30:50 UTC
Oops, this is a dupe of bug #496131 and seems to be fixed with:

https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7951

*** This bug has been marked as a duplicate of bug 496131 ***


Note You need to log in before you can comment on or make changes to this bug.