Bug 52005 - installation program can not find red hat cd-rom in any of my cd-rom drives
installation program can not find red hat cd-rom in any of my cd-rom drives
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-08-18 02:07 EDT by Koray Kavukcuoglu
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-15 12:52:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
history of my bug with RedHat Support. (5.53 KB, text/plain)
2001-08-18 02:14 EDT, Koray Kavukcuoglu
no flags Details

  None (edit)
Description Koray Kavukcuoglu 2001-08-18 02:07:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
I have a quite long problem history with the guys at RedHat support and I 
will attach those at the attechment part.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.boot from CD or diskette
2.choose any ype of installation (expert, text, normal, specifying 
3.choose language of installation (english or turkish)
4.choose keyboard type (us or turq or turkish turq_latin5)
5.choose the installation location (Local CDROM or Hard Drive)

Actual Results:  intstallation program can not find RedHat CDROM in any of 
your CDROM direves. Please insert RedHat CD...

Expected Results:  it should continue installation properly

Additional info:

included in the attachment.
Comment 1 Koray Kavukcuoglu 2001-08-18 02:14:34 EDT
Created attachment 28381 [details]
history of my bug with RedHat Support.
Comment 2 Brent Fox 2001-08-18 11:34:50 EDT
Please try this:  Make a boot floppy with the boot.img file in the /images
directory on the cdrom.  If you have a linux system around already, put the
cdrom and the floppy in the system and run:
'dd if=/mnt/cdrom/images/boot.img of=/dev/fd0 bs=1440k'

On a Windows system, you can run the 'rawrite' command in the /dosutils
directory on the cdrom.  Rawrite will then prompt you for which file to use. 
Select the boot.img file in the /images directory.

Once you've got the boot floppy, put it in the system and reboot.  The install
should start and then you will be given the option of doing either a Hard Drive
install or a CDROM install.  Put the Red Hat CD in the drive and select CDROM. 
Hopefully, the install will proceed without problems.

I think the problem is this:  For 7.1, we switched to 2.88MB boot images on the
cdrom.  This allows us to include more drivers for things like SCSI cards, RAID
controllers, etc. in the first stage of the install.  The problem is that a few
cdrom drives (it's the motherboard's problem, actually), can't boot from a
2.88MB boot image.  Booting off a floppy gets around that problem because the
floppy is using a 1.44MB boot image.  Then, the floppy hands off to the cdrom fo
 r the second stage install, and things work fine. 

Does this solve the problem?
Comment 3 Koray Kavukcuoglu 2001-08-18 17:02:46 EDT
Things are getting strange I think. I have created the boot disk with the 
rawrite utility and booted from floopy, chose CDROM and the installation began. 
I have proceeded and made all package selections, configurations,... Then the 
package installation step has come. First the formatting of drives was being 
carried out but the program crashed. After a 15 minutes of no progress on the 
making ext2 file system propagation bar and seeing that the hdd led was not 
even blinking I did reset my computer. But afterwards I can not achive to pass 
through cdrom or hard drive installation option as before. I even again made a 
boot floppy with rawrite and tried the same procedure, but nothing changes. I 
have tried this method maybe for 10 ten times. thank you and hope to hear from 
Comment 4 Matt Wilson 2001-08-20 13:43:13 EDT
try booting with "linux ide=nodma" at the boot: prompt
Comment 5 Koray Kavukcuoglu 2001-08-20 15:22:45 EDT
unfortunately, it did not work. I have the same error. Also I wonder why I can 
not install from the har drive also.
Comment 6 Koray Kavukcuoglu 2001-08-26 16:09:46 EDT
I think you need additional information. here's what I get after I boot from 
the floppy / text expert:
/tmp/ide-cd.o: unresolved symbol unregister cdrom_R010c2aac
/tmp/ide-cd.o: unresolved symbol cdrom_fops_R4eb9a092
/tmp/ide-cd.o: unresolved symbol cdrom_number_of_slots_Ree65f265
going to insmod cdromfs.o (path is null)
going to insmod cdrom.o (path is null)
error 2 reading header: cpio:Bad magic
Comment 7 Brent Fox 2001-08-27 10:39:32 EDT
It looks like the problem is related to the cd somehow.  Considering that you've
replaced the discs themselves, I'm wondering if you aren't seeing hardware
problems.  What is the make and model of the cdrom drive?
Comment 8 Koray Kavukcuoglu 2001-08-27 11:02:41 EDT
Comment 9 Brent Fox 2001-08-27 11:49:06 EDT
I don't know what to tell you.  I have never seen these kind of errors before. 
Do other operating systems, such as Windows, work on this machine?  I'm inclined
to think that there are some hardware troubles here.
Comment 10 Koray Kavukcuoglu 2001-08-27 13:11:42 EDT
if you like I can pass you my system summary from Windos 98 which I am using 
now. also I have used Windows NT4.0 and Red Hat 5.2 and Red Hat 6.2 on this 
machine. those errors were from virtual console.
Comment 11 Koray Kavukcuoglu 2001-08-27 15:32:18 EDT
I am totally lost. just before I have installed my redhat 5.2, but just problem 
with the X server that i know, i had before, and solved before. that problem is 
due to my graphics card which is not in the default list and during custom 
installation of graphics card to match right one was so hard. than immediately 
i tried again 7.1 but same happened. then i installed my red hat 6.0, but i 
think those CDs are no more usefull i think, everything goes well untill the 
formatting partitions section, but then on it crashes. So what i see is old 
versions of redhat installers can find my CD. why this one CAN'T?
Comment 12 Brent Fox 2001-08-29 15:34:10 EDT
I'm sorry that you are having all these troubles trying to install 7.1.  I have
no idea what could be causing these problems.  Are you interested in trying the
latest public beta for the next version of Red Hat?  I can't think of anything
else to try...
Comment 13 Koray Kavukcuoglu 2001-09-02 03:09:55 EDT
yes I'd like to try it.
Comment 14 Jeremy Katz 2001-09-05 22:01:54 EDT
This truly does look like hardware trouble.  The 2.4 kernel used in Red Hat
Linux 7.1 stresses the hardware more than previous releases have and will hit
corner cases like this sometimes.  If you would like to try the beta of our next
release, you can download it from most mirrors of ftp.redhat.com or directly at

If possible, could you try with a different CD-ROM drive or see if the results
are any different with Roswell?
Comment 15 Koray Kavukcuoglu 2001-09-10 13:51:26 EDT
I have already tried with a different CDROM drive. HP 8250i CDR/CRW drive. But 
I am sorry about trying with Roswell, since I have a 56K modem connection, it 
will take hours for me to download.
Comment 16 Brent Fox 2001-09-13 18:17:42 EDT
I see.  Yes, that would take quite a long time to download.  I don't really know
what to recommend to you.  So you saw the exact same problem with a different
CDROM drive?
Comment 17 Koray Kavukcuoglu 2001-09-15 12:02:23 EDT
first i want say that we here in Turkey are very sorry and angry about the 
terrorist attack to USA. As a nation living very close with terrorism, we share 
your sorrow and anger. I hope the terrorists will be found in very near future.

yes, i did so, my own cdrom is CREATIVE CDROM drive, and i tried with a HP 
8250i again.
thank you very much.
Comment 18 Brent Fox 2001-09-17 18:13:38 EDT
   Thank you for your kind words.  I think I will never understand the desire to
target innocent people, no matter what country or religion they might belong to.
 To the people of the USA, the world is a different place than it was a week ago.

Having said that, I still don't know what is causing 7.1 to not install on your
system.  I'm pretty much out of ideas... :(
Comment 19 Brent Fox 2001-09-27 15:34:11 EDT
Have you had any further luck with this problem?
Comment 20 Koray Kavukcuoglu 2001-09-29 01:45:49 EDT
unfortunately no, i couldn't, yesterday I have received RedHat 6.2 and I will 
try that one. after installing that one i will try to upgrade and see if it 
works or not.
Comment 21 Brent Fox 2001-10-01 11:46:39 EDT
Ok.  Let me know how it goes.
Comment 22 Brent Fox 2001-10-15 12:18:47 EDT
Any more info here?
Comment 23 Koray Kavukcuoglu 2001-10-15 12:51:59 EDT
excuse me about the long delay. I have installed 6.2 and it works very fine 
now. I have tried to install 7.1 again but it did not work again. Also I have 
made iso images of the two cd's with mkisofs and checked with md5sum. although 
it seems that iso images are ok, I could not achieve hard drive installation 
also. One more thing. I have replaced the vmlinuz file on the boot disk of 7.1 
with that of 6.2 and the installation program could achieve to see the RedHat 
CD. I could proceed until package installation but during package installation 
somewhere in the middle the installation stops and kills all processes and 
reboots. this has been the same for several times that I again installed 6.2
Comment 24 Brent Fox 2001-10-16 15:20:00 EDT
I don't know what else to do.  Upgrading from 6.2 to 7.1 has worked for me in
all my tests.  I really can't explain what's going on.  I hate to close bugs as
'worksforme', but in this case I don't know what else to do...

Note You need to log in before you can comment on or make changes to this bug.