Bug 520074 - /usr/bin/otfdump conflicts with libotf
Summary: /usr/bin/otfdump conflicts with libotf
Keywords:
Status: CLOSED DUPLICATE of bug 496131
Alias: None
Product: Fedora
Classification: Fedora
Component: openmpi
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 09:21 UTC by Mikko Huhtala
Modified: 2014-08-31 23:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-08 18:21:57 UTC


Attachments (Terms of Use)

Description Mikko Huhtala 2009-08-28 09:21:55 UTC
Description of problem:

Having openmpi installed keeps libotf from being installed because /usr/bin/otfdump conflicts. I don't know if this should be reported here or against libotf.

Version-Release number of selected component (if applicable):

openmpi-1.3.1-1.fc11.i586
libotf-0.9.8-2.fc11.i586

Comment 1 Cong Ma 2009-08-28 13:27:05 UTC
I had this problem too. The package openmpi owns the file /usr/bin/otfdump but it didn't actually create it. I have openmpi installed, and a recent update of Emacs pulled in libotf, which resulted in a conflict. I checked and there's no such file "otfdump". On my i386 system there /is/ a file /usr/bin/i586-redhat-linux-gnu-otfdump (owned by openmpi), which suggests that /usr/bin/otfdump were possibly meant to be a symlink to it. Anyway, it's a conflict.

Comment 2 Arthur Lutz 2009-09-09 14:11:45 UTC
I am also affected by this bug. Any ETA ?

Comment 3 Doug Ledford 2009-09-09 15:22:14 UTC
Jay Fenlason has been working on it and last I knew he had a set of packages ready to go.  I'll ping him.

OK, talked to him in IRC, expect his commit and build soon.

Comment 4 Mikko Huhtala 2009-09-11 10:49:42 UTC
openmpi-1.3.3-3.fc12.i686.rpm on rawhide works for me. It installs /usr/lib/openmpi/1.3.3-gcc/bin/otfdump.

Comment 5 Dominik 'Rathann' Mierzejewski 2009-09-20 19:18:47 UTC
Duplicate of bug 496131?

Comment 6 Jay Fenlason 2009-10-08 18:21:57 UTC

*** This bug has been marked as a duplicate of bug 496131 ***


Note You need to log in before you can comment on or make changes to this bug.