Bug 520149 - All IBM Java on Supplemental CDs are missing copyright information and IBM Java needs to be pulled off Supplemental CDs
Summary: All IBM Java on Supplemental CDs are missing copyright information and IBM Ja...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: java-1.5.0-ibm
Version: 5.4
Hardware: All
OS: All
urgent
urgent
Target Milestone: rc
: ---
Assignee: Lillian Angel
QA Contact: BaseOS QE
URL:
Whiteboard:
: 520165 520166 (view as bug list)
Depends On:
Blocks: RHEL5u4_relnotes 522515 525461
TreeView+ depends on / blocked
 
Reported: 2009-08-28 16:00 UTC by IBM Bug Proxy
Modified: 2010-01-11 23:19 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
All the IBM Java components are available online due to a late detection of missing COPYRIGHT notice. This applies to the Supplementary CD contents for Red Hat Enterprise Linux 5 on all architectures and releases. For more information, refer to the Red Hat Knowledgebase.
Clone Of:
: 522515 525461 (view as bug list)
Environment:
Last Closed: 2009-10-06 12:13:37 UTC


Attachments (Terms of Use)
diff between the spec file from 1.5.0.3 and 1.5.0.10 (18.08 KB, text/plain)
2009-08-28 19:50 UTC, Ben Levenson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1478 normal SHIPPED_LIVE java-1.5.0-ibm bug fix update 2009-10-06 12:13:35 UTC
IBM Linux Technology Center 55792 None None None Never

Description IBM Bug Proxy 2009-08-28 16:00:19 UTC
=Comment: #0=================================================
Stephanie A. Glass <sglass@us.ibm.com> - 
When the certification runs were done for all java versions on all platforms it was determine that
all COPYRIGHT and notices.htm files were missing.  This is due to the repackaging of the java by Red
Hat that they are given by the IBM JTC team.  Several of the files are also not in the correct place
per our Sun Compliance information also.

IBM is requesting that Red Hat pull the IBM Java's that reside on the Supplemental CDs for RHEL 5.4.
 It is not legally allowed to ship IBM Java without those files being present.

IBM is in the process of running the same tests on the versions of java that are on RHN.  IBM will
let Red Hat know if there is an issue with those files also.  We will have more information in the
next few days on the RHN javas.  If it is determine we have a similar problem, we will let Red Hat
know immediately

If you have any questions, please contact me immediately at 512 797-6448.

Thank you in advance

Stephanie Glass LTC PM for SWG

Comment 1 IBM Bug Proxy 2009-08-28 16:10:21 UTC
------- Comment From sglass@us.ibm.com 2009-08-28 12:09 EDT-------
IBM has determine that the tar ball that they gave has all necessary files in the correct place.  These issues are due to the repackaging that Red Hat goes through.

Comment 2 Ben Levenson 2009-08-28 17:23:09 UTC
I see the COPYRIGHT files in the following RPMS:

=== tree-i386/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.i386.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/COPYRIGHT

=== tree-ia64/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.ia64.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/COPYRIGHT

=== tree-ppc/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.ppc64.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/COPYRIGHT

=== tree-ppc/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.ppc.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/COPYRIGHT

=== tree-s390x/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.s390.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/COPYRIGHT

=== tree-s390x/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.s390x.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/COPYRIGHT

=== tree-x86_64/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.i386.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/COPYRIGHT

=== tree-x86_64/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.x86_64.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/COPYRIGHT

=== tree-i386/Supplementary/java-1.5.0-ibm-1.5.0.10-1jpp.4.el5.i386.rpm
/usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT

=== tree-ppc/Supplementary/java-1.5.0-ibm-1.5.0.10-1jpp.4.el5.ppc64.rpm
/usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT

=== tree-ppc/Supplementary/java-1.5.0-ibm-1.5.0.10-1jpp.4.el5.ppc.rpm
/usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT

=== tree-s390x/Supplementary/java-1.5.0-ibm-1.5.0.10-1jpp.4.el5.s390.rpm
/usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT

=== tree-s390x/Supplementary/java-1.5.0-ibm-1.5.0.10-1jpp.4.el5.s390x.rpm
/usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT

=== tree-x86_64/Supplementary/java-1.5.0-ibm-1.5.0.10-1jpp.4.el5.i386.rpm
/usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT

=== tree-x86_64/Supplementary/java-1.5.0-ibm-1.5.0.10-1jpp.4.el5.x86_64.rpm
/usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT


"COPYRIGHT" (all caps) is missing from the java-1.6.0-ibm packages, but the 
following "copyright" files are present:

=== tree-i386/Supplementary/java-1.6.0-ibm-devel-1.6.0.5-1jpp.1.el5.i386.rpm
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/content/en/copyright
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/copyright

=== tree-ppc/Supplementary/java-1.6.0-ibm-devel-1.6.0.5-1jpp.1.el5.ppc64.rpm
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/content/en/copyright
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/copyright

=== tree-ppc/Supplementary/java-1.6.0-ibm-devel-1.6.0.5-1jpp.1.el5.ppc.rpm
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/content/en/copyright
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/copyright

=== tree-s390x/Supplementary/java-1.6.0-ibm-devel-1.6.0.5-1jpp.1.el5.s390.rpm
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/content/en/copyright

=== tree-s390x/Supplementary/java-1.6.0-ibm-devel-1.6.0.5-1jpp.1.el5.s390x.rpm
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/content/en/copyright

=== tree-x86_64/Supplementary/java-1.6.0-ibm-devel-1.6.0.5-1jpp.1.el5.i386.rpm
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/content/en/copyright
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/copyright

=== tree-x86_64/Supplementary/java-1.6.0-ibm-devel-1.6.0.5-1jpp.1.el5.x86_64.rpm
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/content/en/copyright
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.5/copyright

Comment 3 Ben Levenson 2009-08-28 17:31:26 UTC
Here's what I'm finding for "Notices.htm".

@ tree-i386/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.i386.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/jre/Notices.htm

@ tree-i386/Supplementary/java-1.4.2-ibm-devel-1.4.2.13-1jpp.1.el5.i386.rpm
/usr/share/doc/java-1.4.2-ibm-devel-1.4.2.13/sdk/Notices.htm

@ tree-ia64/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.ia64.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/jre/Notices.htm

@ tree-ia64/Supplementary/java-1.4.2-ibm-devel-1.4.2.13-1jpp.1.el5.ia64.rpm
/usr/share/doc/java-1.4.2-ibm-devel-1.4.2.13/sdk/Notices.htm

@ tree-ppc/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.ppc64.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/jre/Notices.htm

@ tree-ppc/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.ppc.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/jre/Notices.htm

@ tree-ppc/Supplementary/java-1.4.2-ibm-devel-1.4.2.13-1jpp.1.el5.ppc64.rpm
/usr/share/doc/java-1.4.2-ibm-devel-1.4.2.13/sdk/Notices.htm

@ tree-ppc/Supplementary/java-1.4.2-ibm-devel-1.4.2.13-1jpp.1.el5.ppc.rpm
/usr/share/doc/java-1.4.2-ibm-devel-1.4.2.13/sdk/Notices.htm

@ tree-s390x/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.s390.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/jre/Notices.htm

@ tree-s390x/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.s390x.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/jre/Notices.htm

@ tree-s390x/Supplementary/java-1.4.2-ibm-devel-1.4.2.13-1jpp.1.el5.s390.rpm
/usr/share/doc/java-1.4.2-ibm-devel-1.4.2.13/sdk/Notices.htm

@ tree-s390x/Supplementary/java-1.4.2-ibm-devel-1.4.2.13-1jpp.1.el5.s390x.rpm
/usr/share/doc/java-1.4.2-ibm-devel-1.4.2.13/sdk/Notices.htm

@ tree-x86_64/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.i386.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/jre/Notices.htm

@ tree-x86_64/Supplementary/java-1.4.2-ibm-1.4.2.13-1jpp.1.el5.x86_64.rpm
/usr/share/doc/java-1.4.2-ibm-1.4.2.13/jre/Notices.htm

@ tree-x86_64/Supplementary/java-1.4.2-ibm-devel-1.4.2.13-1jpp.1.el5.i386.rpm
/usr/share/doc/java-1.4.2-ibm-devel-1.4.2.13/sdk/Notices.htm

@ tree-x86_64/Supplementary/java-1.4.2-ibm-devel-1.4.2.13-1jpp.1.el5.x86_64.rpm
/usr/share/doc/java-1.4.2-ibm-devel-1.4.2.13/sdk/Notices.htm

@ tree-i386/Supplementary/java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5.i386.rpm
/usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm

@ tree-ppc/Supplementary/java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5.ppc64.rpm
/usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm

@ tree-ppc/Supplementary/java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5.ppc.rpm
/usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm

@ tree-s390x/Supplementary/java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5.s390.rpm
/usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm

@ tree-s390x/Supplementary/java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5.s390x.rpm
/usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm

@ tree-x86_64/Supplementary/java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5.i386.rpm
/usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm

@ tree-x86_64/Supplementary/java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5.x86_64.rpm
/usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm

But there are no "Notices.htm" files in the java-1.6.0-ibm packages.

Comment 4 Ben Levenson 2009-08-28 17:36:24 UTC
Please review comment #2 and comment #3. 

* COPYRIGHT and Notices.htm are present in the 1.5.0 and 1.4.2 packages. 
* "COPYRIGHT" is NOT present in the 1.6.0 packages, but "copyright" is there.
* Notices.htm is NOT present in the 1.6.0 packages.

Would you be more specific about what needs to be where? Thanks.

Comment 5 Lillian Angel 2009-08-28 17:39:13 UTC
I verified this. It seems as if the Java 1.5.0 IBM packages are fine.

Comment 6 IBM Bug Proxy 2009-08-28 17:42:50 UTC
------- Comment From sglass@us.ibm.com 2009-08-28 13:42 EDT-------
The trouble is not in the RPMs that reside on either the ISOs or RHN, but once you install the java product, they are not in what is installed.  Does that make sense?

Comment 7 Lillian Angel 2009-08-28 17:47:26 UTC
not particularly. i don't understand. when they are installed, those files do not exist?

Comment 8 IBM Bug Proxy 2009-08-28 18:00:28 UTC
------- Comment From sglass@us.ibm.com 2009-08-28 13:56 EDT-------
> not particularly. i don't understand. when they are installed, those files do
> not exist?

Yes, that is exactly what I mean

Comment 9 Lillian Angel 2009-08-28 18:05:01 UTC
That does not seem to be the case. I just installed the RPMs:

[14:03 towel:i386]$ ls /usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm 
/usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm

[14:03 towel:i386]$ ls /usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT /usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT

I think there must be some special case where this is not happening...

Comment 11 Ben Levenson 2009-08-28 18:31:37 UTC
I can't reproduce this either:
$ sudo yum localinstall java-1.5.0-ibm-*
Loaded plugins: rhnplugin, security
Setting up Local Package Process
<snip>
Resolving Dependencies
--> Running transaction check
<snip>
Dependencies Resolved
<snip>
Installed:
  java-1.5.0-ibm.i386 1:1.5.0.10-1jpp.4.el5 
  java-1.5.0-ibm.x86_64 1:1.5.0.10-1jpp.4.el5
  java-1.5.0-ibm-devel.i386 1:1.5.0.10-1jpp.4.el5
  java-1.5.0-ibm-devel.x86_64 1:1.5.0.10-1jpp.4.el5                      

Dependency Installed:
  compat-libstdc++-33.i386 0:3.2.3-61
  compat-libstdc++-33.x86_64 0:3.2.3-61
  libXmu.i386 0:1.0.2-5
  libXp.i386 0:1.0.0-8.1.el5    

Complete!

$ rpm -q java-1.5.0-ibm-1.5.0.10-1jpp.4.el5 java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5
java-1.5.0-ibm-1.5.0.10-1jpp.4.el5.x86_64
java-1.5.0-ibm-1.5.0.10-1jpp.4.el5.i386
java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5.i386
java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5.x86_64


$ ls /usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT 
/usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT
$ rpm -qf /usr/share/doc/java-1.5.0-ibm-1.5.0.10/COPYRIGHT 
java-1.5.0-ibm-1.5.0.10-1jpp.4.el5.x86_64
java-1.5.0-ibm-1.5.0.10-1jpp.4.el5.i386

$ ls /usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm 
/usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm
$ rpm -qf /usr/share/doc/java-1.5.0-ibm-devel-1.5.0.10/en/Notices.htm 
java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5.i386
java-1.5.0-ibm-devel-1.5.0.10-1jpp.4.el5.x86_64

Comment 13 Ludek Smid 2009-08-28 18:38:38 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
All the IBM Java components are available online due to a late detection of missing COPYRIGHT notice. This affects the Supplementary CD contents for Red Hat Enterprise Linux 5 on all architectures and releases.

Comment 16 Ben Levenson 2009-08-28 19:41:46 UTC
I can't find any significant difference between the version we shipped
in RHEL5 GA (1.5.0.3) and what we have in 5.4 (1.5.0.10). Here's a look
at the COPYRIGHT and Notices.htm files in the s390x tarball. None of these
paths have changed:

$ find 1bm-1.5.0.3/ -name COPYRIGHT
1bm-1.5.0.3/COPYRIGHT
$ find 1bm-1.5.0.10/ -name COPYRIGHT
1bm-1.5.0.10/COPYRIGHT

$ find 1bm-1.5.0.3/ -name Notices.htm
1bm-1.5.0.3/docs/en/Notices.htm
$ find 1bm-1.5.0.10/ -name Notices.htm
1bm-1.5.0.10/docs/en/Notices.htm

I'll attach a diff between the 1.5.0.3 and 1.5.0.10 spec files, but I don't see
anything in there to explain the behavior reported in this bug.

Comment 17 IBM Bug Proxy 2009-08-28 19:50:32 UTC
------- Comment From sglass@us.ibm.com 2009-08-28 15:47 EDT-------
Hi red Hat.
Yes, we have figured out that at least the missing files are due to them being in a different directory structure then what the tool expected.  We are asking the JTC team if the directory structure is that important or just having the file is all we need.  There may be an issue with the tool itself.  We are now checking into that.

The issue we have right now is that the people to answer these questions are overseas and unavailable right now.  We will not have answers until Tuesday next week as it is a country wide holiday on Monday.

Thank you for all you work so far.

Comment 18 Ben Levenson 2009-08-28 19:50:33 UTC
Created attachment 359111 [details]
diff between the spec file from 1.5.0.3 and 1.5.0.10

Diff between the spec file from RHEL5 GA (1.5.0.3) andRHEL5.4 (1.5.0.10).

Comment 19 Ben Levenson 2009-08-28 19:52:23 UTC
(In reply to comment #18)
> diff between the spec file from 1.0.5.3 and 1.0.5.10

meant to say "from 1.5.0.3 and 1.5.0.10"

Comment 21 Ryan Lerch 2009-08-31 03:41:18 UTC
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1,3 @@
-All the IBM Java components are available online due to a late detection of missing COPYRIGHT notice. This affects the Supplementary CD contents for Red Hat Enterprise Linux 5 on all architectures and releases.+All the IBM Java components are available online due to a late detection of missing COPYRIGHT notice. This applies to the Supplementary CD contents for Red Hat Enterprise Linux 5 on all architectures and releases.
+
+For more information, refer to the Red Hat Knowledgebase.

Comment 22 Ben Levenson 2009-09-01 14:47:06 UTC
(In reply to comment #17)
> ------- Comment From sglass@us.ibm.com 2009-08-28 15:47 EDT-------
> 
> The issue we have right now is that the people to answer these questions are
> overseas and unavailable right now.  We will not have answers until Tuesday
> next week as it is a country wide holiday on Monday.


Any updates?

Comment 28 Lillian Angel 2009-09-17 14:12:30 UTC
(In reply to comment #22)
> (In reply to comment #17)
> > ------- Comment From sglass@us.ibm.com 2009-08-28 15:47 EDT-------
> > 
> > The issue we have right now is that the people to answer these questions are
> > overseas and unavailable right now.  We will not have answers until Tuesday
> > next week as it is a country wide holiday on Monday.
> 
> 
> Any updates?  

New packages are being tested at the moment. We tracked down the issue. Some files were in fact missing or in the wrong places.

Comment 32 Stephanie Glass 2009-10-02 13:26:04 UTC
As far as in the wrong place:  (want to make sure this is clear)

I am not sure exactly what is the wrong spot.  IBM is ok if the copyright/license/notices files are located either in the common location for all such files or within our java itself as we ship it.

Thanks

Comment 38 errata-xmlrpc 2009-10-06 12:13:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1478.html

Comment 39 Suzanne Yeghiayan 2009-10-08 19:38:55 UTC
*** Bug 520165 has been marked as a duplicate of this bug. ***

Comment 40 Daniel Mach 2009-10-23 12:12:19 UTC
*** Bug 520166 has been marked as a duplicate of this bug. ***

Comment 41 IBM Bug Proxy 2009-11-10 19:41:31 UTC
------- Comment From sglass@us.ibm.com 2009-11-10 14:40 EDT-------
This is fixed.


Note You need to log in before you can comment on or make changes to this bug.