Bug 520154 - installer leaks filedescriptors of /dev/null
Summary: installer leaks filedescriptors of /dev/null
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Joel Andres Granados
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 16:23 UTC by John Reiser
Modified: 2009-09-17 14:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 14:45:38 UTC


Attachments (Terms of Use)

Description John Reiser 2009-08-28 16:23:45 UTC
Description of problem: During "Starting installation process" when the installer is reading the headers from .rpm files on DVD, the installer process has over 200 filedesriptors open to /dev/null.  


Version-Release number of selected component (if applicable):
anaconda-12.17 (rawhide of Friday Aug 28)

How reproducible: every time


Steps to Reproduce:
1. boot DVD for install, proceed until "Starting installation process"
2. switch to VT2, use "ps ax" to find installer process "python /usr/bin/anaconda"
3. ls -l /proc/<pid_of_installer>/fd
  
Actual results: about 250 open filedescriptors, with over 200 of them being /dev/null


Expected results: at most a couple dozen open file descriptors


Additional info:

Comment 1 Joel Andres Granados 2009-09-02 12:13:59 UTC
So I don't forget:
This is probably caused by the new tee stuff in execWithRedirect.

Comment 2 Joel Andres Granados 2009-09-17 14:45:38 UTC
This will be fixed in the next version of anaconda (12-26)


Note You need to log in before you can comment on or make changes to this bug.