Bug 520162 - nss-devel no longer provides pkgconfig(nss)
nss-devel no longer provides pkgconfig(nss)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-08-28 13:06 EDT by Warren Togami
Modified: 2013-01-10 00:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 18:46:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-08-28 13:06:09 EDT
389-adminutil-devel-1.1.8-4.fc12.i686 requires pkgconfig(nss)
conexus-nss-devel-0.9.0-1.fc12.i686 requires pkgconfig(nss) >= 0:3.11
libpathfinder-nss-devel-1.0.0-2.fc12.i686 requires pkgconfig(nss) >= 0:2.0.0
mozldap-devel-6.0.5-6.fc12.i686 requires pkgconfig(nss) >= 0:3.11
svrcore-devel-4.0.4-5.fc12.i686 requires pkgconfig(nss) >= 0:3.12.3.99.3
xmlsec1-nss-devel-1.2.12-1.fc12.i686 requires pkgconfig(nss) >= 0:1.4

[warren@newcaprica tmp]$ rpm -qp --provides nss-devel-3.12.3.99.3-6.fc12.x86_64.rpm 
pkgconfig(nss) = 3.12.3.99.3
nss-devel = 3.12.3.99.3-6.fc12
nss-devel(x86-64) = 3.12.3.99.3-6.fc12

Prior to the split, nss-devel provided the virtual provides pkgconfig(nss).  RPM automatically generates these presumably from properly formatted pkgconfig files?

nss-3.12.3.99.3-24.fc12 is missing this virtual provides.
Comment 1 Elio Maldonado Batiz 2009-08-28 16:16:13 EDT
Temporary hack coming soon to unblock people until I provide a real fix.
Comment 2 Elio Maldonado Batiz 2009-08-31 12:09:33 EDT
Temporary hacked no longer needed and removed. The problem was caused by a syntactically invalid nss.pc being generated. Some of the version tags were not replaced by numbers. By changing the nss.spec file to track the nss-softokn and nss-util versions independently of the nss version the necessary replacements occur as needed.

Note You need to log in before you can comment on or make changes to this bug.