Bug 520179 - yum downloads files from file:/// repositories before installing them
Summary: yum downloads files from file:/// repositories before installing them
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-28 18:50 UTC by Chuck Ebbert
Modified: 2014-01-21 23:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-12 21:21:14 UTC


Attachments (Terms of Use)

Description Chuck Ebbert 2009-08-28 18:50:37 UTC
Description of problem:
yum downloads files from file:/// repositories before installing them

Version-Release number of selected component (if applicable):
yum-3.2.23-14.fc12
python-urlgrabber-3.9.0-8.fc12

How reproducible:
Run 'yum update' with repositories mounted on a cifs filesystem.
Watch yum download all the updates before installing.

Repo:

[buffalo-rawhide]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
baseurl=file:///media/l/linux/fedora/mirror/rawhide/$basearch/os/
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

Comment 1 Chuck Ebbert 2009-08-28 18:55:31 UTC
Also happens on F-11 with yum-3.2.23-3.fc11 and python-urlgrabber-3.0.0-15.fc11

Comment 2 seth vidal 2009-09-01 19:47:24 UTC
I cannot replicate this on any version of yum right now. Could you post all of your .repo files and your yum.conf just to be sure:

do you have an /etc/yum.repos.d dir AND an /etc/yum/repos.d dir?

thanks

Comment 3 Chuck Ebbert 2009-09-02 02:00:13 UTC
(In reply to comment #2)
> I cannot replicate this on any version of yum right now. Could you post all of
> your .repo files and your yum.conf just to be sure:
> 
> do you have an /etc/yum.repos.d dir AND an /etc/yum/repos.d dir?

no.

I straced yum and it stats the .rpm packages it's going to install. Then it opens /proc/mounts and reads it, then stats all the mounted ext3 and ext4 filesystems. It really looks like it's trying to see if the file:/// URL corresponds to a mounted local filesystem, but seems not to understand that cifs is one of them.

Comment 4 seth vidal 2009-09-02 04:02:39 UTC
just for the sake of argument - can you setup a truly local repo and test it so we can be certain this is a cifs thing and not something else?

Comment 5 Chuck Ebbert 2009-09-07 22:51:46 UTC
(In reply to comment #4)
> just for the sake of argument - can you setup a truly local repo and test it so
> we can be certain this is a cifs thing and not something else?  

I tried it from a locally mounted ext2 filesystem and it still downloaded the packages before installing. I did notice two things though, that are the same on the CIFS and local mounts:

1. The repo is owned by a user other than root.

2. There is a drpms directory but it's empty because I don't mirror that.

Comment 6 seth vidal 2009-09-08 13:55:30 UTC
The owner of the rpms makes no difference whatsoever.

Please disable the presto plugin and re-run your test.

Comment 7 seth vidal 2009-09-17 14:27:48 UTC
Chuck - a reping on the thing from last week - please disable the presto plugin and re-run your test.

Thanks,

Comment 8 seth vidal 2009-10-12 21:21:14 UTC
I can't replicate this - and neither can anyone else afaict.

if you can do the tests from above that would help

reopen then

Comment 9 Chuck Ebbert 2009-10-16 11:58:53 UTC
yum-presto is not even installed on one of the machines where this happens

Comment 10 seth vidal 2009-10-16 12:05:39 UTC
Are any of these machines rhts machines? Is there any way I can take a look b/c I have no idea what's happening here.

Comment 11 seth vidal 2009-10-19 20:36:05 UTC
okay - I've setup a cifs share using samba3, mounted it using mount and added it as a repo with the repo config of:

[cifs-empty]
name = cifs
baseurl=file:///mnt/cifs-test/tmp/empty-repo
enabled=0
gpgcheck=0


I enabled the repo and I installed one pkg from this repository.

The package was accessed directly from this location, it was not downloaded to /var/cache/yum/....

So I cannot make this one happen at all. Any suggestions on how to duplicate this bug?


Note You need to log in before you can comment on or make changes to this bug.