Bug 520184 - SELinux cause firstboot to freeze
SELinux cause firstboot to freeze
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-08-28 15:30 EDT by Niels Haase
Modified: 2009-08-28 16:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-28 16:36:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels Haase 2009-08-28 15:30:42 EDT
Description of problem:
After Rawhide install from 20090827, the system comes up and firstboot appears. No keyboard typing or mouse movement are possible. No switch to vty is possible. ACPI events and ssh are still working, so I assume that the system is still running. Booting into runlevel 3 starts the cli firstboot fine. After that, switch to runlevel 5 is no problem, X is working like a charm. But also in runlevel 5, if you start firstboot, it freeze the same way.

It looks like a SELinux problem here:

kernel: type=1107 audit(1251487005.880:143): user pid=1150 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc: denied { send_msg } for msgtype=method_call interface=org.freedesktop.DBus member=Hello dest=org.freedesktop.DBus spid=1999 scontext=unconfined_u:unconfined_r:firstboot_t:s0-s0:c0.c1023 tcontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tclass=dbus

boot with selinux=0 can be used for a workarround.


Version-Release number of selected component (if applicable):
selinux-policy-3.6.28-8.fc12.noarch
libselinux-2.0.85-2.fc12.x86_64
libselinux-utils-2.0.85-2.fc12.x86_64
libselinux-python-2.0.85-2.fc12.x86_64
selinux-policy-targeted-3.6.28-8.fc12.noarch
libselinux-devel-2.0.85-2.fc12.x86_64
firstboot-1.108-1.fc12.x86_64



How reproducible:
100%

Steps to Reproduce:
1. Install rawhide (at least 20090827
2. reboot
3. see that firstboot freeze
  
Actual results:
firstboot is not working

Expected results:
fistboot working

Additional info:
Comment 1 Daniel Walsh 2009-08-28 16:36:09 EDT
Fixed in selinux-policy-3.6.29-1.fc12.noarch

Note You need to log in before you can comment on or make changes to this bug.