Bug 520207 - Filesystem label does not match kernel command line parameter
Summary: Filesystem label does not match kernel command line parameter
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: NeedsRetesting
: 521471 (view as bug list)
Depends On:
Blocks: F12Beta, F12BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2009-08-28 22:22 UTC by Adam Williamson
Modified: 2022-06-22 13:11 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-20 05:14:15 UTC
Type: ---


Attachments (Terms of Use)

Description Adam Williamson 2009-08-28 22:22:33 UTC
Found this bug while testing Dracut: https://fedoraproject.org/wiki/Test_Day:2009-08-27_Dracut . If you take the live image from that page, convert it to a live USB image with livecd-iso-to-disk, and try and boot it, it fails. To make it work you have to edit the kernel command line and change:

root=live:LABEL=blahblahblahblah

to:

root=live:LABEL=LIVE

i.e., the label that's written to the filesystem by livecd-iso-to-disk does not match the label it puts in the bootloader configuration. Some additional comments from IRC:

<haraldh> it generates the wrong kernel command line
<haraldh> or labels the filesystem wrong
<haraldh> either way
<adamw> why does it work with the old initrd system then? :)
<haraldh> ah, for dracut they generate a rule
<haraldh> if the LABEL is recognized
<haraldh> then the partition is mounted
<haraldh> and the squash image is mounted
<haraldh> so if the partition label does not match the label on the kernel command line
<haraldh> well
<haraldh> it's dracut specific
<haraldh> so definitely a new codepath

This is high severity and a release blocker because converting the live CD images to USB images is a very common thing for people to do, and if we were to release F12 with this broken, it'd be a significant problem.

Comment 1 Bob Arendt 2009-09-07 01:06:53 UTC
This hit the recent "F12 snapshot 1", reported as Bug 521471

Comment 2 Michael Monreal 2009-09-09 13:11:06 UTC
I am also running into this.

root=live:LABEL=LIVE does not seem to work for me as a workaround, though (on my own livecd-creator-created ISO). Is there a way to get the correct LABEL somehow?

Comment 3 Bob Arendt 2009-09-09 14:52:20 UTC
Use /sbin/dosfslabel or /sbin/e2label (depends on partition type).

Comment 4 Mike C 2009-09-09 15:24:35 UTC
Thanks Bob - yes once you have the correct label and apply it to the kernel boot line then it does boot correctly.

Comment 5 Adam Williamson 2009-09-09 20:18:17 UTC
*** Bug 521471 has been marked as a duplicate of this bug. ***

Comment 6 Adam Williamson 2009-09-11 15:48:45 UTC
assigning to dcantrell, who will be picking up livecd-tools according to denise.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 John Poelstra 2009-09-11 15:50:24 UTC
This bug was reviewed at the Fedora 12 Beta Blocker bug meeting on 2009-09-11. Per Denise, this package is now being maintained by dcantrell who is currently on vacation.  Will revisit at next week's meeting.

Comment 8 Warren Togami 2009-09-13 05:01:19 UTC
/sbin/dosfslabel can have some surprises.

[root@newcaprica ~]# /sbin/dosfslabel /dev/sdb1
There are differences between boot sector and its backup.
Differences: (offset:original/backup)
  90:fa/0e, 91:fc/1f, 92:31/be, 93:c0/77, 94:8e/7c, 95:d0/ac, 96:bc/22
  , 97:b4/c0, 98:7b/74, 99:06/0b, 100:57/56, 101:8e/b4, 102:c0/0e, 103:b9/bb
  , 104:08/07, 106:bf/cd, 107:b4/10, 108:7b/5e, 109:f3/eb, 110:a5/f0
  , 111:8e/32, 112:d8/e4, 113:bb/cd, 114:78/16, 115:00/cd, 116:0f/19
  , 117:b4/eb, 118:37/fe, 119:0f/54, 120:a0/68, 121:56/69, 122:88/73
  , 123:16/20, 124:a1/69, 125:2c/73, 127:d2/6e, 128:78/6f, 129:15/74
  , 130:b1/20, 131:06/61, 132:89/20, 133:3f/62, 134:89/6f, 135:47/6f
  , 136:02/74, 137:f3/61, 138:64/62, 139:a5/6c, 140:8a/65, 141:0e/20
  , 142:18/64, 143:7c/69, 144:88/73, 145:4d/6b, 146:f8/2e, 147:cd/20
  , 148:13/20, 149:eb/50, 150:27/6c, 151:f6/65, 152:45/61, 153:f0/73
  , 154:7f/65, 155:75/20, 156:08/69, 157:66/6e, 158:8b/73, 159:45/65
  , 160:f8/72, 161:66/74, 162:a3/20, 163:1c/61, 164:7c/20, 165:b4/62
  , 166:08/6f, 167:cd/6f, 168:13/74, 169:72/61, 170:13/62, 171:20/6c
  , 172:e4/65, 173:75/20, 174:0f/66, 175:c1/6c, 176:ea/6f, 177:08/70
  , 178:42/70, 179:89/79, 180:16/20, 181:1a/61, 182:7c/6e, 183:83/64
  , 184:e1/0d, 185:3f/0a, 186:89/70, 187:0e/72, 188:18/65, 189:7c/73
  , 190:fb/73, 191:bb/20, 192:aa/61, 193:55/6e, 194:b4/79, 195:41/20
  , 196:8a/6b, 197:16/65, 198:a1/79, 199:2c/20, 200:cd/74, 201:13/6f
  , 202:72/20, 203:10/74, 204:81/72, 205:fb/79, 206:55/20, 207:aa/61
  , 208:75/67, 209:0a/61, 210:f6/69, 211:c1/6e, 212:01/20, 213:74/2e
  , 214:05/2e, 215:c6/2e, 216:06/20, 217:02/0d, 218:7d/0a, 220:66/00
  , 221:a1/00, 222:f8/00, 223:7d/00, 224:bb/00, 226:7e/00, 227:e8/00
  , 228:10/00, 230:66/00, 231:81/00, 232:3e/00, 233:24/00, 234:7e/00
  , 235:40/00, 236:65/00, 237:55/00, 238:77/00, 239:0f/00, 240:85/00
  , 241:c3/00, 243:e9/00, 244:3a/00, 245:02/00, 246:bd/00, 247:01/00
  , 249:66/00, 250:03/00, 251:06/00, 252:1c/00, 253:7c/00, 254:66/00
  , 255:31/00, 256:d2/00, 257:eb/00, 258:4f/00, 259:55/00, 260:e8/00
  , 261:d5/00, 263:66/00, 264:0f/00, 265:b7/00, 266:fd/00, 267:b9/00
  , 268:10/00, 270:66/00, 271:52/00, 272:66/00, 273:50/00, 274:06/00
  , 275:53/00, 276:57/00, 277:6a/00, 278:10/00, 279:89/00, 280:e6/00
  , 281:66/00, 282:60/00, 283:8a/00, 284:16/00, 285:a1/00, 286:2c/00
  , 287:1e/00, 288:16/00, 289:1f/00, 290:b4/00, 291:42/00, 292:cd/00
  , 293:13/00, 294:1f/00, 295:66/00, 296:61/00, 297:8d/00, 298:64/00
  , 299:10/00, 300:72/00, 301:10/00, 302:5d/00, 303:66/00, 304:01/00
  , 305:f8/00, 306:29/00, 307:fd/00, 308:c1/00, 309:e7/00, 310:09/00
  , 311:01/00, 312:fb/00, 313:21/00, 314:ed/00, 315:75/00, 316:c6/00
  , 317:c3/00, 318:66/00, 319:60/00, 320:31/00, 321:c0/00, 322:8a/00
  , 323:16/00, 324:a1/00, 325:2c/00, 326:cd/00, 327:13/00, 328:66/00
  , 329:61/00, 330:e2/00, 331:c2/00, 332:c6/00, 333:06/00, 334:02/00
  , 335:7d/00, 336:4f/00, 337:5d/00, 338:66/00, 339:52/00, 340:66/00
  , 341:50/00, 342:55/00, 343:53/00, 344:66/00, 345:0f/00, 346:b7/00
  , 347:36/00, 348:18/00, 349:7c/00, 350:66/00, 351:0f/00, 352:b7/00
  , 353:3e/00, 354:1a/00, 355:7c/00, 356:66/00, 357:f7/00, 358:f6/00
  , 359:31/00, 360:c9/00, 361:87/00, 362:ca/00, 363:66/00, 364:f7/00
  , 365:f7/00, 366:e8/00, 367:6b/00, 369:29/00, 370:ce/00, 371:39/00
  , 372:f5/00, 373:76/00, 374:02/00, 375:89/00, 376:f5/00, 377:c0/00
  , 378:e4/00, 379:06/00, 380:41/00, 381:08/00, 382:e1/00, 383:88/00
  , 384:c5/00, 385:88/00, 386:d6/00, 387:8a/00, 388:16/00, 389:a1/00
  , 390:2c/00, 391:95/00, 392:b4/00, 393:02/00, 394:bd/00, 395:10/00
  , 397:66/00, 398:60/00, 399:cd/00, 400:13/00, 401:66/00, 402:61/00
  , 403:72/00, 404:17/00, 405:66/00, 406:0f/00, 407:b6/00, 408:c8/00
  , 409:c1/00, 410:e0/00, 411:09/00, 412:5b/00, 413:01/00, 414:c3/00
  , 415:5d/00, 416:66/00, 417:58/00, 418:66/00, 419:5a/00, 420:66/00
  , 421:01/00, 422:c8/00, 423:29/00, 424:cd/00, 425:75/00, 426:a7/00
  , 427:c3/00, 428:4d/00, 429:75/00, 430:de/00, 431:95/00, 432:d1/00
  , 433:2e/00, 434:fc/00, 435:7d/00, 436:75/00, 437:df/00, 438:31/00
  , 439:f6/00, 440:8e/00, 441:d6/00, 442:bc/00, 443:b0/00, 444:7b/00
  , 445:8e/00, 446:de/00, 447:66/00, 448:8f/00, 449:06/00, 450:78/00
  , 452:be/00, 453:e7/00, 454:7d/00, 455:ac/00, 456:20/00, 457:c0/00
  , 458:74/00, 459:09/00, 460:b4/00, 461:0e/00, 462:bb/00, 463:07/00
  , 465:cd/00, 466:10/00, 467:eb/00, 468:f2/00, 469:98/00, 470:cd/00
  , 471:16/00, 472:cd/00, 473:19/00, 474:eb/00, 475:fe/00, 476:3b/00
  , 477:2e/00, 478:fc/00, 479:7d/00, 480:76/00, 481:04/00, 482:8b/00
  , 483:2e/00, 484:fc/00, 485:7d/00, 486:c3/00, 487:42/00, 488:6f/00
  , 489:6f/00, 490:74/00, 491:20/00, 492:65/00, 493:72/00, 494:72/00
  , 495:6f/00, 496:72/00, 497:0d/00, 498:0a/00, 504:20/00, 505:5c/00
  , 506:1a/00, 508:7f/00
  Not automatically fixing this.

Comment 9 Warren Togami 2009-09-14 00:56:55 UTC
It appears the only way I could recover from this above error was to reformat the disk.  fsck couldn't fix it.

Comment 10 Warren Togami 2009-09-14 15:23:19 UTC
I suspect that dracut insisting upon a LABEL might be wrong.

mkfs.vfat creates filesystems with a blank label.  We should require setting a label in order to use this?  mkliveinitrd did not have this requirement right?

Comment 11 Andreas Tunek 2009-09-18 12:30:47 UTC
Still happens in snapshot 2, but I guess that was expected.

Comment 12 John Poelstra 2009-09-18 15:52:48 UTC
This bug was reviewed at the Fedora 12 Beta Blocker bug meeting on 2009-09-18. It is believed to be fixed in  livecd-tools-028-1.fc12.

 It needs to be retested.  Please help us by reporting if the latest package addresses the originally reported issue.  Thanks.

Comment 13 Bob Arendt 2009-09-18 15:58:03 UTC
I'll try testing tonight;  But the fix should really get pushed to F11 (& F10?) since the F12 live media will probably be generated on a user's F11 system.

Comment 14 Warren Togami 2009-09-18 16:26:56 UTC
The bug was written to the .ISO file itself.  The old livecd-iso-to-disk should (theoretically) handle it just fine.

http://alt.fedoraproject.org/pub/alt/nightly-composes/
I did not test writing the ISO to LiveUSB using liveusb-creator.  Could someone test that with a nightly Live images?

Comment 15 Adam Williamson 2009-09-18 18:50:15 UTC
to be clear - this should be fixed in any nightly build dated 20090918 or later.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 16 Bob Arendt 2009-09-20 01:42:20 UTC
Just tested using both:
http://alt.fedoraproject.org/pub/alt/nightly-composes/xfce/xfce-i386-20090917.16.iso
http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/desktop-x86_64-20090917.16.iso

I've verified that the problem's fixed in these generated images.  The syslinux.cfg entry now loads the root by UUID instead of LABEL;  Example:

append initrd=initrd0.img root=live:UUID=6C3A-9A46 rootfstype=vfat rw liveimg overlay=UUID=6C3A-9A46 quiet  rhgb 

Both images boot and bring up a login.  The desktop-live image is healthy.  The xfce-live image has gdm(?) issues, but startxfce4 runs fine by hand from a text console.

Looks like *this* bug is fixed.

Comment 17 Heidi John 2022-06-22 13:11:59 UTC
Professional dissertation writing services are not cheap. You can expect to pay anything from $1,000 to $5,000 for a dissertation or thesis. The most expensive services will charge you up to $10,000 or more.

The price of the service https://ask4essay.com/how-much-does-professional-dissertation-writing-services-cost/ is determined by the level of expertise and experience that you require. If you want an experienced writer who has written dissertations before and has an excellent track record then it will cost more than someone who is new to the profession and does not have as much experience.


Note You need to log in before you can comment on or make changes to this bug.