Bug 520220 - perl-4:5.10.0 attempts to install both x86_64 and i586???
Summary: perl-4:5.10.0 attempts to install both x86_64 and i586???
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-29 03:18 UTC by bob mckay
Modified: 2009-09-04 12:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-04 11:57:03 UTC


Attachments (Terms of Use)

Description bob mckay 2009-08-29 03:18:15 UTC
Description of problem:
Update of F11 after initial install fails

Version-Release number of selected component (if applicable):
perl-IO-Compress-Base-2.008-73.fc11(x86_64) or anything else that relies on perl

How reproducible:
always

Steps to Reproduce:
1. install 64-bit F11 (on a virtualbox vm, but I don't think this is relevant)
2. enable 64-bit install and update repos only (i.e. default repos)
3. attempt to update
(results below happen for a full update, but also if I restrict the update to perl-IO-Compress-Base-2.008-73.fc11(x86_64) - or as far as I can tell, anything else that depends on perl)
  
Actual results:
Test Transaction Errors:   file /usr/share/doc/glibc-2.10.1/NEWS from install of glibc-2.10.1-4.i686 conflicts with file from package glibc-2.10.1-2.x86_64
  file /usr/lib/perl5/5.10.0/File/Spec.pm conflicts between attempted installs of perl-4:5.10.0-73.fc11.x86_64 and perl-4:5.10.0-68.fc11.i586
  file /usr/lib/perl5/5.10.0/File/Spec/Cygwin.pm conflicts between attempted installs of perl-4:5.10.0-73.fc11.x86_64 and perl-4:5.10.0-68.fc11.i586
  file /usr/lib/perl5/5.10.0/File/Spec/Epoc.pm conflicts between attempted installs of perl-4:5.10.0-73.fc11.x86_64 and perl-4:5.10.0-68.fc11.i586
  file /usr/lib/perl5/5.10.0/File/Spec/Functions.pm conflicts between attempted installs of perl-4:5.10.0-73.fc11.x86_64 and perl-4:5.10.0-68.fc11.i586
  file /usr/lib/perl5/5.10.0/File/Spec/Mac.pm conflicts between attempted installs of perl-4:5.10.0-73.fc11.x86_64 and perl-4:5.10.0-68.fc11.i586
  file /usr/lib/perl5/5.10.0/File/Spec/OS2.pm conflicts between attempted installs of perl-4:5.10.0-73.fc11.x86_64 and perl-4:5.10.0...


Expected results:
update succeeds

Additional info:
I can't be certain whether the first error is coming from an underlying problem in the perl rpm, but the rest certainly seem to be (I don't understand why the first conflict arises at all, because /usr/share/doc/glibc-2.10.1/NEWS is supposed to be noarch)

Comment 1 Chris Weyl 2009-09-04 09:12:21 UTC
Hm, that is weird.  Can you attach the complete yum output to this bug, please?  It's quite difficult to work through dependency issues like this without it.

Comment 2 bob mckay 2009-09-04 11:57:03 UTC
I'm sorry Chris, I think this has turned out to be a virtualbox problem after all. If I install virtualbox with SMP on my hardware, I get the above problem (but I should mention that it's subsequent to a couple of kernel oopses; I had assumed that they were random timing problems, and hence irrelevant to the above reproducible problem, but perhaps not. Perhaps one of them corrupts the yum db somehow). If I install it with just a single cpu, the installation proceeds fine and I don't see the above. So I'm guessing it should be left as one of those unfathomable mysteries beyond the reach of mere mortals (sorry, I should have remembered to change the status).

Comment 3 Lubomir Rintel 2009-09-04 12:18:46 UTC
wat


Note You need to log in before you can comment on or make changes to this bug.