Bug 520248 - Xemacs crashes after click on the menu bar
Summary: Xemacs crashes after click on the menu bar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xemacs
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-29 18:22 UTC by Matthias Scheutz
Modified: 2009-09-10 03:43 UTC (History)
1 user (show)

Fixed In Version: 20090217-3.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 03:43:22 UTC


Attachments (Terms of Use)

Description Matthias Scheutz 2009-08-29 18:22:24 UTC
Description of problem:

Clicking anywhere on the menu bar causes xemacs to crash with the following terminal output:

Fatal error: assertion failed, file menubar-x.c, line 579, ABORT()

Fatal error (6).

Your files have been auto-saved.
Use `M-x recover-session' to recover them.

Your version of XEmacs was distributed with a PROBLEMS file that may describe
your crash, and with luck a workaround.  Please check it first, but do report
the crash anyway.                                                            

Please report this bug by invoking M-x report-emacs-bug, or by selecting
`Send Bug Report' from the Help menu.  If that won't work, send ordinary
email to `xemacs-beta@xemacs.org'.  *MAKE SURE* to include this entire  
output from this crash, especially including the Lisp backtrace, as well as
the XEmacs configuration from M-x describe-installation (or equivalently,  
the file `Installation' in the top of the build tree).                     

*Please* try *hard* to obtain a C stack backtrace; without it, we are unlikely
to be able to analyze the problem.  Locate the core file produced as a result 
of this crash (often called `core' or `core.<process-id>', and located in     
the directory in which you started XEmacs or your home directory), and type   

  gdb /usr/bin/xemacs core

then type `where' at the debugger prompt.  No GDB on your system?  You may
have DBX, or XDB, or SDB.  (Ask your system administrator if you need help.)
If no core file was produced, enable them (often with `ulimit -c unlimited')
in case of future recurrance of the crash.                                  

Lisp backtrace follows:

  # (unwind-protect ...)
  # (unwind-protect ...)
  # (unwind-protect ...)
  # (unwind-protect ...)
  # (unwind-protect ...)
  # (unwind-protect ...)
  # (unwind-protect ...)
  # (unwind-protect ...)
  # bind (inhibit-quit) 
  # (condition-case ... . error)
  # (catch top-level ...)


Version-Release number of selected component (if applicable):

XEmacs 21.5  (beta28) "fuki" [Lucid] (i386-redhat-linux, Mule) of Sun Mar  8 2009 on x86-5.fedora.phx.redhat.com

How reproducible:

Click on the menu bar in xemacs

Steps to Reproduce:
1. Click anywhere on the menu bar.
2.
3.
  
Actual results:

xemacs crashes

Expected results:

No crash, but successful pull up of the menu

Additional info:

Note that it also crashes when executing "m-x new-frame" with the same error message.  It does *not* crash when started with the --vanilla option in either case.


This bug seems to be similar to Bug 480845 -  assertion failed in menubar, but for fedora 11.

Comment 1 Jerry James 2009-08-31 17:29:27 UTC
I can't reproduce this crash.  The fact that -vanilla makes it go away is suspicious.  Are you willing to share the contents of your .xemacs/init.el and .xemacs/custom.el?  Chances are good that something in there is leading to the crash.  If you aren't willing to share, can you use a binary search-like procedure to identify what in init.el or custom.el makes the crash possible?

If you are willing to share with me, but not the entire world, feel free to send the files to me in private email.  I will use them only to identify the trigger for the crash, then delete them.

Comment 2 Jerry James 2009-08-31 17:52:23 UTC
Even with your init.el and custom.el, both clicking on the menubar and executing M-x new-frame work for me.  I notice that you are using the i686 build, while I am using the x86_64 build.  That might be significant.  Otherwise, we have some environmental difference that leads to this crash for you.

I'll look more closely at the backtrace in bug 480845 as well.  That seems to indicate a buggy menubar definition.

Do you have anything in ~/.xemacs besides init.el and custom.el?  What does "rpm -qa | grep xemacs" print?

Comment 3 Fedora Update System 2009-09-01 19:37:01 UTC
xemacs-packages-base-20090217-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xemacs-packages-base-20090217-3.fc11

Comment 4 Fedora Update System 2009-09-03 00:30:32 UTC
xemacs-packages-base-20090217-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xemacs-packages-base'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9235

Comment 5 Fedora Update System 2009-09-10 03:43:12 UTC
xemacs-packages-base-20090217-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.