Bug 520257 - Installation fails with ERROR: unhandled exception occurred: AttributeError: DB_BACKEND
Summary: Installation fails with ERROR: unhandled exception occurred: AttributeError: ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Spacewalk
Classification: Community
Component: Installation
Version: 0.6
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Devan Goodwin
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space07
TreeView+ depends on / blocked
 
Reported: 2009-08-29 20:43 UTC by Magnus Glantz
Modified: 2012-03-06 09:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-05 21:47:11 UTC


Attachments (Terms of Use)

Description Magnus Glantz 2009-08-29 20:43:09 UTC
Description of problem:

When installing Spacewalk 0.6 (I also hit this problem using nightly build packages) on FC11 the installation (issued by: rhn-satellite-activate --disconnected) fails with the following Python exception/backtrace:

ERROR: unhandled exception occurred:
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-activate", line 45, in <module>
    sys.exit(abs(mod.main() or 0))
  File "/usr/share/rhn/satellite_tools/rhn_satellite_activate.py", line 573, in main
    db_backend = CFG.DB_BACKEND
  File "/usr/share/rhn/common/rhnConfig.py", line 341, in __getattr__
    raise AttributeError(key)
AttributeError: DB_BACKEND

Version-Release number of selected component (if applicable):
(Nightly build versions below)
spacewalk-0.6.4-1.fc11.noarch
spacewalk-admin-0.6.3-1.fc11.noarch
spacewalk-backend-0.7.2-1.fc11.noarch
spacewalk-backend-app-0.7.2-1.fc11.noarch
spacewalk-backend-applet-0.7.2-1.fc11.noarch
spacewalk-backend-config-files-0.7.2-1.fc11.noarch
spacewalk-backend-config-files-common-0.7.2-1.fc11.noarch
spacewalk-backend-config-files-tool-0.7.2-1.fc11.noarch
spacewalk-backend-iss-0.7.2-1.fc11.noarch
spacewalk-backend-iss-export-0.7.2-1.fc11.noarch
spacewalk-backend-package-push-server-0.7.2-1.fc11.noarch
spacewalk-backend-server-0.7.2-1.fc11.noarch
spacewalk-backend-sql-0.7.2-1.fc11.noarch
spacewalk-backend-tools-0.7.2-1.fc11.noarch
spacewalk-backend-xml-export-libs-0.7.2-1.fc11.noarch
spacewalk-backend-xmlrpc-0.7.2-1.fc11.noarch
spacewalk-backend-xp-0.7.2-1.fc11.noarch
spacewalk-base-0.7.2-1.fc11.noarch
spacewalk-base-minimal-0.7.2-1.fc11.noarch
spacewalk-branding-0.6.8-1.fc11.noarch
spacewalk-certs-tools-0.6.3-1.fc11.noarch
spacewalk-config-0.7.1-1.fc11.noarch
spacewalk-cypress-0.7.2-1.fc11.noarch
spacewalk-doc-indexes-0.6.1-1.fc11.noarch
spacewalk-grail-0.7.2-1.fc11.noarch
spacewalk-html-0.7.2-1.fc11.noarch
spacewalk-java-0.7.2-1.fc11.noarch
spacewalk-java-config-0.7.2-1.fc11.noarch
spacewalk-java-lib-0.7.2-1.fc11.noarch
spacewalk-monitoring-0.7.1-1.fc11.noarch
spacewalk-monitoring-selinux-0.6.12-1.fc11.noarch
spacewalk-moon-0.7.2-1.fc11.noarch
spacewalk-pxt-0.7.2-1.fc11.noarch
spacewalk-schema-0.7.1-1.fc11.noarch
spacewalk-search-0.6.11-1.fc11.noarch
spacewalk-selinux-0.6.13-1.fc11.noarch
spacewalk-setup-0.7.2-1.fc11.noarch
spacewalk-sniglets-0.7.2-1.fc11.noarch
spacewalk-taskomatic-0.7.2-1.fc11.noarch

0.6.5 versions below:
spacewalk-0.6.4-1.fc11.noarch
spacewalk-admin-0.6.3-1.fc11.noarch
spacewalk-backend-0.6.30-1.fc11.noarch
spacewalk-backend-app-0.6.30-1.fc11.noarch
spacewalk-backend-applet-0.6.30-1.fc11.noarch
spacewalk-backend-config-files-0.6.30-1.fc11.noarch
spacewalk-backend-config-files-common-0.6.30-1.fc11.noarch
spacewalk-backend-config-files-tool-0.6.30-1.fc11.noarch
spacewalk-backend-iss-0.6.30-1.fc11.noarch
spacewalk-backend-iss-export-0.6.30-1.fc11.noarch
spacewalk-backend-package-push-server-0.6.30-1.fc11.noarch
spacewalk-backend-server-0.6.30-1.fc11.noarch
spacewalk-backend-sql-0.6.30-1.fc11.noarch
spacewalk-backend-tools-0.6.30-1.fc11.noarch
spacewalk-backend-xml-export-libs-0.6.30-1.fc11.noarch
spacewalk-backend-xmlrpc-0.6.30-1.fc11.noarch
spacewalk-backend-xp-0.6.30-1.fc11.noarch
spacewalk-base-0.6.19-1.fc11.noarch
spacewalk-base-minimal-0.6.19-1.fc11.noarch
spacewalk-branding-0.6.8-1.fc11.noarch
spacewalk-certs-tools-0.6.3-1.fc11.noarch
spacewalk-config-0.6.13-1.fc11.noarch
spacewalk-cypress-0.6.19-1.fc11.noarch
spacewalk-doc-indexes-0.6.1-1.fc11.noarch
spacewalk-grail-0.6.19-1.fc11.noarch
spacewalk-html-0.6.19-1.fc11.noarch
spacewalk-java-0.6.46-1.fc11.noarch
spacewalk-java-config-0.6.46-1.fc11.noarch
spacewalk-java-lib-0.6.46-1.fc11.noarch
spacewalk-monitoring-0.6.7-1.fc11.noarch
spacewalk-monitoring-selinux-0.6.12-1.fc11.noarch
spacewalk-moon-0.6.19-1.fc11.noarch
spacewalk-pxt-0.6.19-1.fc11.noarch
spacewalk-repo-0.6-5.fc11.noarch
spacewalk-schema-0.6.22-1.fc11.noarch
spacewalk-search-0.6.11-1.fc11.noarch
spacewalk-selinux-0.6.13-1.fc11.noarch
spacewalk-setup-0.6.21-1.fc11.noarch
spacewalk-sniglets-0.6.19-1.fc11.noarch
spacewalk-taskomatic-0.6.46-1.fc11.noarch

How reproducible:
Install FC11, apply all the latest patches, install Spacewalk 0.6.5 repo. Try and install Spacewalk.

Steps to Reproduce:
1. Install FC11 - apply all the latest patches
2. rpm -Uvh http://spacewalk.redhat.com/yum/0.6/Fedora/11/i386/os/Packages/spacewalk-repo-0.6-5.fc11.noarch.rpm
3. yum -y install spacewalk
4. rhn-satellite-activate --disconnected
  
Actual results:
# rhn-satellite-activate --disconnected
/usr/share/rhn/common/rhnLib.py:18: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
/usr/share/rhn/common/rhnLib.py:25: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
  import popen2
/usr/share/rhn/server/rhnServer/server_lib.py:19: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
/usr/share/rhn/server/rhnServer/server_token.py:21: DeprecationWarning: the sets module is deprecated
  from sets import Set
NOTE: using backup cert as default: /etc/sysconfig/rhn/rhn-entitlement-cert.xml

ERROR: unhandled exception occurred:
Traceback (most recent call last):
  File "/usr/bin/rhn-satellite-activate", line 45, in <module>
    sys.exit(abs(mod.main() or 0))
  File "/usr/share/rhn/satellite_tools/rhn_satellite_activate.py", line 573, in main
    db_backend = CFG.DB_BACKEND
  File "/usr/share/rhn/common/rhnConfig.py", line 341, in __getattr__
    raise AttributeError(key)
AttributeError: DB_BACKEND

Expected results:
Installation starts and finishes without errors.

Additional info:
$ uname -r
2.6.29.6-217.2.16.fc11.i686.PAE

All Python related:
[mglantz@mglantz ~]$ rpm -qa|grep -i python|sort
at-spi-python-1.26.0-1.fc11.i586
audit-libs-python-1.7.13-1.fc11.i586
compizconfig-python-0.7.8-3.fc11.i586
cracklib-python-2.8.13-4.i586
dbus-python-0.83.0-5.fc11.i586
gamin-python-0.1.10-4.fc11.i586
gnome-python2-2.26.1-1.fc11.i586
gnome-python2-applet-2.26.0-3.fc11.i586
gnome-python2-bonobo-2.26.1-1.fc11.i586
gnome-python2-canvas-2.26.1-1.fc11.i586
gnome-python2-desktop-2.26.0-3.fc11.i586
gnome-python2-extras-2.25.3-6.fc11.i586
gnome-python2-gconf-2.26.1-1.fc11.i586
gnome-python2-gnome-2.26.1-1.fc11.i586
gnome-python2-gnomekeyring-2.26.0-3.fc11.i586
gnome-python2-gnomeprint-2.26.0-3.fc11.i586
gnome-python2-gnomevfs-2.26.1-1.fc11.i586
gnome-python2-gtkhtml2-2.25.3-6.fc11.i586
gnome-python2-libegg-2.25.3-6.fc11.i586
gnome-python2-libwnck-2.26.0-3.fc11.i586
gstreamer-python-0.10.16-1.fc11.i586
gtk-vnc-python-0.3.8-8.fc11.i586
libproxy-python-0.2.3-10.fc11.i586
libselinux-python-2.0.80-1.fc11.i586
libsemanage-python-2.0.31-4.fc11.i586
libuser-python-0.56.9-3.i586
libvirt-python-0.6.2-14.fc11.i586
libxml2-python-2.7.3-3.fc11.i586
libxslt-python-1.1.24-4.fc11.i586
mod_python-3.3.1-10.i586
newt-python-0.52.10-3.fc11.i586
notify-python-0.1.1-7.fc11.i586
policycoreutils-python-2.0.62-12.12.fc11.i586
python-2.6-9.fc11.i586
python-bugzilla-0.5.1-2.fc11.noarch
python-cheetah-2.0.1-5.fc11.i586
python-configobj-4.6.0-1.fc11.noarch
python-crypto-2.0.1-18.i586
python-decorator-3.0.1-2.fc11.noarch
python-decoratortools-1.7-3.fc11.noarch
python-devel-2.6-9.fc11.i586
python-fedora-0.3.15-1.fc11.noarch
python-feedparser-4.1-8.fc11.noarch
python-gammu-1.24.0-1.fc11.i586
python-gzipstream-1.4.0-18.fc11.noarch
python-imaging-1.1.6-14.fc11.i586
python-iniparse-0.3.0-2.fc11.noarch
python-krbV-1.0.13-9.fc11.i586
python-ldap-2.3.6-1.fc11.i586
python-libs-2.6-9.fc11.i586
python-magic-5.03-2.fc11.i586
python-netaddr-0.6.3-1.fc11.noarch
python-nose-0.10.4-2.fc11.noarch
python-numeric-24.2-13.fc11.i586
python-offtrac-0.0.3-1.fc11.noarch
python-paramiko-1.7.5-1.fc11.noarch
python-paste-1.7.2-2.fc11.noarch
python-pgsql-0.9.7-3.fc11.i586
python-psyco-1.6-2.fc11.i586
python-pycurl-7.19.0-1.fc11.i586
python-reportlab-2.1-4.fc11.noarch
python-setuptools-0.6c9-4.fc11.noarch
python-sexy-0.1.9-8.fc11.i586
python-simplejson-2.0.9-2.fc11.i586
python-slip-0.1.15-3.fc11.noarch
python-slip-dbus-0.1.15-3.fc11.noarch
python-slip-gtk-0.1.15-3.fc11.noarch
python-sqlalchemy-0.5.4-1.p2.fc11.noarch
python-suds-0.3.6-1.fc11.noarch
python-urlgrabber-3.0.0-15.fc11.noarch
python-virtinst-0.400.3-8.fc11.noarch
python-xlib-0.14-4.fc11.noarch
rpm-python-4.7.1-1.fc11.i586
wxPython-2.8.9.2-2.fc11.i586

Comment 1 Jan Pazdziora 2009-08-31 09:01:38 UTC
Devan, could you please investigate what's happening with the database backends? Thank you.

Comment 2 Magnus Glantz 2009-08-31 11:20:28 UTC
This was Oracle related, the database had not been properly setup. Not sure what the problem was but I'm guessing it was end-user related *cough*

I recreated the issue by removing spacewalk and Oracle and then
1) Installing Spacewalk and Oracle
2) running 'rhn-satellite-activate --disconnected' before running 'satellite-setup --disconnected'

Comment 3 Magnus Glantz 2009-09-05 21:47:11 UTC
Closing as 'Notabug'


Note You need to log in before you can comment on or make changes to this bug.