Bug 520264 - comps.pot is not required anymore
comps.pot is not required anymore
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: 436824
  Show dependency treegraph
 
Reported: 2009-08-29 17:48 EDT by Piotr Drąg
Modified: 2014-03-16 23:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-01 20:01:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Piotr Drąg 2009-08-29 17:48:39 EDT
Currently there is both POTFILES.in file and comps.pot in Comps repository. It's confusing, because if we are generating PO files dynamically using intltool (POTFILES.in), we shouldn't have POT file in the project. And since this POT file is not up to date for long time, I think it's not necessary anymore. Could you please remove it, to avoid further mistakes?
Comment 1 Bill Nottingham 2009-09-01 18:06:45 EDT
As I understand it, if it's not in CVS, then translators have to check for updates manually. Is that correct?
Comment 2 Piotr Drąg 2009-09-01 18:17:41 EDT
No, Transifex is doing it for them. If there is no comps.pot in CVS, it will be created dynamically by Transifex, just like l10n.gnome.org works. Every change in source files will cause refresh of translation files.

Also it's how Transifex *is* configured now, because no one refreshed comps.pot in this cycle yet. This request of removal of the POT file is just to make things clear.
Comment 3 Bill Nottingham 2009-09-01 20:01:42 EDT
OK, nuked.
Comment 4 Bill Nottingham 2011-03-03 15:12:23 EST
FYI - adding this back b/c of transifex 1.0 workflow changes.

Note You need to log in before you can comment on or make changes to this bug.