Bug 52027 - Installer problems - X server starts but crashes with Gdk-error **: Fatal IO error 104
Installer problems - X server starts but crashes with Gdk-error **: Fatal IO ...
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-08-19 04:14 EDT by Dana Bourgeois
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-08-21 14:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dana Bourgeois 2001-08-19 04:14:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Windows NT 5.0; U)

Description of problem:
The complete message is:

   Gdk-ERROR **: Fatal IO error 104 (Connection reset by peer) on Xserver :1
   install exited abnormally

I didn't hit this at first but once I hit it I couldn't get past it.  I tried the several things mentioned in the manual and the help screen but only
going to text mode worked.  Then I stumbled on the fact that going into expert mode and lying about having a driver disk clears the error.
One doesn't even have to have a floppy in the drive.  Accept 'yes' for a Driver disk, lie about it being in the drive, wait for it to return the error
and reboot into graphics installer mode.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Any error in the installation which results in an abnormal exit of the installer

Additional info:

I am using the above workaround in trying to get 7.1 installed.  I now have other problems and will file bugs on them.
Comment 1 Brent Fox 2001-08-21 14:34:42 EDT
Can you look on VC4 and see if there are any error messages there?
Comment 2 Brent Fox 2001-08-31 10:23:40 EDT
Closing due to inactivity. Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.