Bug 520270 - kernel freezes during boot from F12 Alpha DVD
Summary: kernel freezes during boot from F12 Alpha DVD
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-30 00:27 UTC by Aram Agajanian
Modified: 2009-09-05 02:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-05 02:43:39 UTC


Attachments (Terms of Use)
output of lspci -nn (1.62 KB, text/plain)
2009-08-30 00:27 UTC, Aram Agajanian
no flags Details

Description Aram Agajanian 2009-08-30 00:27:02 UTC
Created attachment 359179 [details]
output of lspci -nn

Description of problem:
When I boot the kernel from the F12 Alpha DVD, the computer freezes.  

When the kernel boots, I see a lot of text go by starting with "Loading vmlinuz".  The second of last line of the text "detecting hardware..."  I believe that the last line is "waiting for hardware to initialize..."

After that, I believe that the video mode is being set because the font size becomes smaller.  There is a steady cursor which is on the left side of the screen about 40% from the top.

When the computer freezes, it can be rebooted with C-A-D.

I see exactly the same results whether I select any of the following options on the initial menu:

= Install or upgrade an existing system
= Install system with basic video driver
= Rescue installed system

Version-Release number of selected component (if applicable):
The kernel from the Fedora 12 Alpha DVD (i386 architecture).

How reproducible:
Happens every time.

Steps to Reproduce:
1.  Boot F12 Alpha i386 DVD
2.  Select option in initial menu to boot the kernel.
  
Actual results:
After some initial text is displayed, the computer freezes with a steady cursor.

Expected results:
The boot should not freeze and allow the user to install the OS.

Additional info:

Comment 1 Aram Agajanian 2009-09-02 02:44:18 UTC
I was able to install by adding the kernel parameter radeon.modeset=0.

Comment 2 Aram Agajanian 2009-09-04 03:34:07 UTC
When the kernel was updated to 2.6.31-0.190.rc8.fc12.i686.PAE, the computer became able to boot without the radeon.modeset=0 parameter.  However, the monitor now goes into powersave mode when the graphical boot is running.


Note You need to log in before you can comment on or make changes to this bug.