Bug 520302 - Firefox crashes when loading Java applet
Summary: Firefox crashes when loading Java applet
Keywords:
Status: CLOSED DUPLICATE of bug 538207
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-30 11:26 UTC by SJM
Modified: 2018-04-11 12:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-14 21:32:34 UTC


Attachments (Terms of Use)
Firefox backtrace after cash (29.63 KB, text/plain)
2009-08-30 11:26 UTC, SJM
no flags Details

Description SJM 2009-08-30 11:26:01 UTC
Created attachment 359191 [details]
Firefox backtrace after cash

Description of problem:
I visit a particular website, Firefox crashes (segmentation fault). Generally occurs when the page is loading. The website is password protected "Blackboard learning environment" that many colleges use to provide study material so it's not possible to share the link per say as authentication is required.

I have a feeling this is Java related, thus far with the IceTea plugin disabled I cannot trigger the crash. Further the page may have little 'hidden' applets, although I have triggered the crash when attempting to upload a file using a Java open dialog box as well.

Version-Release number of selected component (if applicable):
(see rpm query below)


How reproducible:
1. Visit a website with an unknown applet(s) as described above
  
Actual results:
Firefox crashes when Java is enabled

Expected results:
Firefox operates per normal

Additional info:

1. Attached backtrace from firefox -g with debug packages installed

2. rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*
gstreamer-plugins-ugly-0.10.12-2.fc11.i586
nspluginwrapper-debuginfo-1.3.0-6.fc11.i586
java-1.6.0-openjdk-plugin-1.6.0.0-27.b16.fc11.i586
mozilla-filesystem-1.9-4.fc11.i586
gstreamer-plugins-base-0.10.23-3.fc11.i586
xulrunner-debuginfo-1.9.1.2-1.fc11.i586
firefox-3.5.2-2.fc11.i586
plymouth-plugin-two-step-0.7.0-0.2009.05.15.1.fc11.i586
PackageKit-gstreamer-plugin-0.4.9-1.fc11.i586
plymouth-plugin-label-0.7.0-0.2009.05.15.1.fc11.i586
nspluginwrapper-1.3.0-6.fc11.i586
gstreamer-plugins-good-0.10.15-4.fc11.i586
alsa-plugins-pulseaudio-1.0.20-2.fc11.i586
anaconda-yum-plugins-1.0-4.fc11.noarch
PackageKit-yum-plugin-0.4.9-1.fc11.i586
totem-mozplugin-2.26.3-1.fc11.i586
firefox-debuginfo-3.5.2-2.fc11.i586
gdm-plugin-fingerprint-2.26.1-13.fc11.i586
setroubleshoot-plugins-2.0.18-5.fc11.noarch
gstreamer-plugins-flumpegdemux-0.10.15-6.fc11.i586
flash-plugin-10.0.32.18-release.i386
xulrunner-1.9.1.2-1.fc11.i586

Comment 1 Matěj Cepl 2009-12-14 21:32:34 UTC

*** This bug has been marked as a duplicate of bug 538207 ***


Note You need to log in before you can comment on or make changes to this bug.