Bug 520314 - Fonts Rendering Problem on x86_64 Fedora 11
Summary: Fonts Rendering Problem on x86_64 Fedora 11
Keywords:
Status: CLOSED DUPLICATE of bug 519317
Alias: None
Product: Fedora
Classification: Fedora
Component: pango
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-30 14:08 UTC by CW Lin
Modified: 2009-08-31 21:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-31 21:25:13 UTC


Attachments (Terms of Use)
Messy Display of Gucharmap (44.84 KB, image/png)
2009-08-30 14:08 UTC, CW Lin
no flags Details

Description CW Lin 2009-08-30 14:08:33 UTC
Created attachment 359193 [details]
Messy Display of Gucharmap

Description of problem:
Some specific size of font can not be properly rendered on the x86_64 system.

Version-Release number of selected component (if applicable):
pangomm-2.24.0-1.fc11.x86_64
pango-1.24.5-1.fc11.x86_64
gucharmap-2.26.2-1.fc11.x86_64
cjkuni-ukai-fonts-0.2.20080216.1-26.fc11.noarch
cjkuni-uming-fonts-0.2.20080216.1-26.fc11.noarch
fontconfig-2.7.1-1.fc11.x86_64

How reproducible:
always on x86_64
never on i386

Steps to Reproduce:
1. Do clean install of x86_64, Fedora 11.
2. Use "Traditional Chinese" during the install process
3. Apply the latest update after installation.
4. Take a look at the font size and DPI setting.
   Make sure they are the same as listed below:
    應用程式字型:Sans,10
    文件字型:    Sans,10
    桌面字型:    Sans,14
    視窗標題字型:Sans Bold 10
    固定寬度字型:Monospace 10
    解析度:96 DPI

5. Open "gucharmap" and search the character "糓" (U+7CD4).
6. Change the font size to 12, 11 and 10.
  
Actual results:
The display of gucharmap become messy.

Expected results:
The display of gucharmap render the font(s) properly.

Additional info:
The following warning message appear on the terminal:
(gucharmap:1997): Pango-WARNING **: shaping failure, expect ugly output.
shape-engine='BasicEngineFc', font='AR PL UMing HK Light 12', text='糔'

(gucharmap:1997): Pango-WARNING **: shaping failure, expect ugly output.
shape-engine='BasicEngineFc', font='AR PL UMing HK Light 11', text='糔'

(gucharmap:1997): Pango-WARNING **: shaping failure, expect ugly output.
shape-engine='BasicEngineFc', font='AR PL UMing HK Light 9.9990234375',
text='糔'

Comment 1 Behdad Esfahbod 2009-08-31 21:25:13 UTC

*** This bug has been marked as a duplicate of bug 519317 ***


Note You need to log in before you can comment on or make changes to this bug.