Bug 520346 - X crashes on start with nouveau (GeForce 9100)
Summary: X crashes on start with nouveau (GeForce 9100)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 12
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: card_NVAA
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-31 01:47 UTC by Steven Usdansky
Modified: 2018-04-11 10:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-03 23:40:14 UTC


Attachments (Terms of Use)
Xorg.0.log (6.56 KB, text/plain)
2009-08-31 01:47 UTC, Steven Usdansky
no flags Details
/var/log/messages (67.56 KB, text/plain)
2009-08-31 10:14 UTC, Steven Usdansky
no flags Details
xorg.conf (3.77 KB, text/plain)
2009-08-31 10:17 UTC, Steven Usdansky
no flags Details
new /var/log/messages (229.75 KB, text/plain)
2009-09-17 00:26 UTC, Steven Usdansky
no flags Details
/var/log/Xorg.0.log; startx from runlevel3 with Xorg -configure generated xorg.conf.new (27.44 KB, text/plain)
2009-11-05 19:22 UTC, Steven Usdansky
no flags Details
xorg.conf that actually works with nouveau driver (3.69 KB, text/plain)
2009-11-07 13:14 UTC, Steven Usdansky
no flags Details
Working xorg.conf for Nov 8 (3.54 KB, text/plain)
2009-11-08 13:32 UTC, Steven Usdansky
no flags Details
xorg log for working nouveau driver - goes with 368039 (89.11 KB, text/plain)
2009-11-08 13:35 UTC, Steven Usdansky
no flags Details
Xorg log file; for corresponding xorg.conf see comment (7.69 KB, text/plain)
2010-02-23 00:22 UTC, Steven Usdansky
no flags Details

Description Steven Usdansky 2009-08-31 01:47:02 UTC
Created attachment 359219 [details]
Xorg.0.log

Description of problem:
X crashes on start with nouveau (GeForce 9100). Can boot into runlevel 3 with nouveau.modeset=0 kernel parameter. Must create xorg.conf with Driver=vesa to use X

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.15-5.20090820git569a17a.fc12.x86_64
xorg-x11-server-Xorg-1.6.99-41.20090825.fc12.x86_64
I'm running the nightly Rawhide lxde spin dated 27Aug

How reproducible:
100% of the time


Steps to Reproduce:
1. Insert CD
2. Boot
  
Actual results:
Blank screen

Expected results:
LXDE in all its glory


Additional info:
smolt profile: http://www.smolts.org/client/show/pub_336b7a02-a02a-4df7-bc74-9dac08eec9a4 
FWIW, nvidia driver doesn't work with this version of Xorg either (I know, not your problem). However, nvidia driver does work with X from Fedora 11, whereas nouveau does not (same problem I'm having here). Xorg.0.log of failed startup (from runlevel 3) is attached

Comment 1 Ben Skeggs 2009-08-31 01:59:54 UTC
I need to see your /var/log/messages also please.

Comment 2 Steven Usdansky 2009-08-31 10:14:21 UTC
Created attachment 359248 [details]
/var/log/messages

Comment 3 Steven Usdansky 2009-08-31 10:17:48 UTC
Created attachment 359249 [details]
xorg.conf

xorg.conf copied from working Rawhide installation on my hard drive; allows me to use X with the live CD.

Comment 4 Ben Skeggs 2009-09-14 01:43:23 UTC
Any updates here?  I don't see nouveau mentioned in your /var/log/messages at all, it looks like the module isn't even loaded (which is what the X driver is complaining about).. If everything's installed correctly, X would be able to load the module automatically

Comment 5 Steven Usdansky 2009-09-14 02:02:39 UTC
No updates -I've been away from my desktop PC for a couple of weeks (and won't be back to it until this ccming Thursday or Friday). Shouldn't the nouveau driver load automatically from the Live CD? If not, what is the proper syntax on the kernel line in grub.conf to get the nouveau driver loaded at boot time?

Comment 6 Ben Skeggs 2009-09-14 02:34:19 UTC
Yes, it should.  Can you give the test day livecd a try and report back, it's linked from https://fedoraproject.org/wiki/Test_Day:2009-09-10.

Thanks!

Comment 7 Steven Usdansky 2009-09-16 18:00:23 UTC
Just tried the test day livecd. No go. At some point in the boot process, even in runlevel 3, the screen goes blank and stays blank.

Comment 8 Steven Usdansky 2009-09-16 19:21:02 UTC
Tried again, this time with the desktop-x86_64-20090915.15.iso (the latest of the nightly composes). Cannot get into X. With nouveau.modeset=0 on the grub kernel line, I can boot into runlevel 3, but running startx gives a blank screen and locks the system. Similarly, booting into runlevel 5 results in a system lockup even with nouveau.modeset=0 (with or without xdriver=vesa) gives me the blank screen and a locked system.

Comment 9 Ben Skeggs 2009-09-16 22:52:28 UTC
Have you got an install by any chance?  If so (or when/if you do do an install) can you:

1. Boot into runlevel 3 with modesetting left on
2. Reboot (CTRL+ALT+DEL will do since you can't see the screen)
3. Start in runlevel 3 with modesetting off, and save /var/log/messages so you can upload it here.

Thanks!

Comment 10 Steven Usdansky 2009-09-17 00:26:07 UTC
Created attachment 361405 [details]
new /var/log/messages

added kernel params for most recent boot:  nouveau.modeset=0 3

possible added kernel params for next most recent boot: 3 modeset=0

added kernel for 3rd-most recent boot: 3

Comment 11 Steven Usdansky 2009-10-01 23:03:53 UTC
No better luck with latest nightly builds. Am I the only person experiencing this bug?

Comment 12 Matěj Cepl 2009-11-05 17:14:41 UTC
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Comment 13 Steven Usdansky 2009-11-05 19:22:06 UTC
Created attachment 367685 [details]
/var/log/Xorg.0.log; startx from runlevel3 with Xorg -configure generated xorg.conf.new

With current (4 Nov) nightly compose on a 1GB USB stick with a 128MB overlay, the bug persists. I tried several work-arounds; none of which seemed to work:
1. Straight Boot
   a. no signal to screen
2. Add nomodeset kernel parameter
   a. saw white and blue bars at bottom of screen during inital boot phase, after which
      (when X starts?) screen apparently getting a signal, but stays dark
3. Add nomodeset vga=795 3 as kernel parameters
   a. Boots fine in text mode
   b. Logged in as root
   c. lsmod shows nouveau driver loaded
   d. startx gives color in top 1/4 of screen, then screen goes dark as in #2 above; cannot
      switch back to tty1 (Ctl-Alt-Backspace has no effect)
4. Repeat #3a-3c
   d. Xorg -configure gives the /root/xorg.conf.new file; partial contents below (no
      device options selected, so that portion not included:
      Section "Module"
	Load  "extmod"
	Load  "dri"
	Load  "dbe"
	Load  "dri2"
	Load  "record"
	Load  "glx"
      EndSection
      Section "Device"
	Identifier  "Card0"
	Driver      "nouveau"
	VendorName  "nVidia Corporation"
	BoardName   "Unknown Board"
	BusID       "PCI:2:0:0"
      EndSection
   e. startx gives color at top 1/4 of screen as in #3 above, then goes dark, but 
      Ctl-Alt-Backspace breaks out

Attached Xorg.0.log from attempt #4

Comment 14 Steven Usdansky 2009-11-07 13:14:56 UTC
Created attachment 367940 [details]
xorg.conf that actually works with nouveau driver 

With nightly compose desktop-x86_64-20091106.16.iso:
1. Created bootable USB stick and booted as-is
   a. same lockup as previous attempt
2. Rebooted into runlevel 3 and logged in as root
   a. Ran Xorg -configure. Returned an xorg.conf.new specifying nv driver
   b. Ran startx. dark screen - Ctl-Alt-Backspace to exit
3. Actually a continuation of #2
   c. Copied working xorg.conf from hard drive to /etc/X11. 
   d. Changed driver from nvidia (which works fine) to nouveau.
   e. Ran startx. X comes up and seems to work just as it should.
FWIW, working xorg.conf is attached.

Comment 15 Ben Skeggs 2009-11-08 04:32:08 UTC
What happens without an xorg.conf ?

Comment 16 Steven Usdansky 2009-11-08 13:32:37 UTC
Created attachment 368039 [details]
Working xorg.conf for Nov 8 

Without xorg.conf the system locks up with a dark screen (screen still apparently receiving a signal). Have to reboot to get out. 

Repeated yesterday's effort, but screen locked up instead of taking me into my gnome session. Kept rebooting and modifying my working (with the nvidia driver) xorg.conf to try to make it work with the 20091106 nightly compose. The attached xorg.conf file worked for me today.

Comment 17 Steven Usdansky 2009-11-08 13:35:13 UTC
Created attachment 368040 [details]
xorg log for working nouveau driver - goes with 368039

Comment 18 Steven Usdansky 2009-11-08 14:36:18 UTC
Just tried to start X using the working xorg.conf file from comment #16. No go - system locks up. I hate it when an experiment doesn't yield reproducible results.

Comment 19 Bug Zapper 2009-11-16 11:50:46 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 20 Ben Skeggs 2010-02-22 03:49:00 UTC
What behaviour do you see if you update to kernel-2.6.32.8-58.fc12 (http://koji.fedoraproject.org/koji/buildinfo?buildID=157041) ?

Comment 21 Steven Usdansky 2010-02-22 19:06:07 UTC
 Booting without xorg.conf: gray screen
 Booting with xorg.conf: broken-up mini version of my desktop but on a black background
In both cases the system locks up and must be power-cycled to reboot. 

NVIDIA-Linux-x86_64-beta-195.30-pkg2.run works fine with the new kernel, if that's any consolation.

Comment 22 Steven Usdansky 2010-02-22 22:43:45 UTC
Just tried nightly compose desktop-x86_64-20100123.19, which includes kernel 2.6.33-0.20.rc5.git0.fc13.x86_64. It's been siting on my hard drive for a while; I just hadn't tried it. Put it on a 1GB USB stick, and booted twice, both times with selinux turned off. The first time, I just let it boot - no signal to screen when X started. The second time, I booted with nomodeset into runlevel 3, ran startx, and up came X. Will try the latest nightly compose to see if it works.

Comment 23 Steven Usdansky 2010-02-23 00:22:30 UTC
Created attachment 395610 [details]
Xorg log file; for corresponding xorg.conf see comment

We've regressed. Current nightly compose (desktop-x86_64-20100221.16.iso) will not permit starting X with the nouveau driver; tried with and without nomodeset and both runlevels 3 and 5. Also tried generating an xorg.conf file, reproduced below. No go. 

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib64/xorg/modules"
	FontPath     "catalogue:/etc/X11/fontpath.d"
	FontPath     "built-ins"
EndSection

Section "Module"
	Load  "dbe"
	Load  "dri"
	Load  "glx"
	Load  "dri2"
	Load  "extmod"
	Load  "record"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "VideoKey"           	# <i>
        #Option     "EXAPixmaps"         	# [<bool>]
	Identifier  "Card0"
	Driver      "nouveau"
	VendorName  "nVidia Corporation"
	BoardName   "Unknown Board"
	BusID       "PCI:2:0:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes "1600x1200" "1280x1024" "1024x768"
	EndSubSection
EndSection

Comment 24 Ben Skeggs 2010-02-23 00:37:38 UTC
The nightly compose likely has mismatched nouveau components.  The log from trying without "nomodeset" would tell for sure, but, F13 no longer supports "nomodeset" with nouveau so that's expected to fail.

Comment 25 Steven Usdansky 2010-06-03 21:55:44 UTC
As far as I'm concerned, this bug can be closed; fixed in F13

Comment 26 Ben Skeggs 2010-06-03 23:40:14 UTC
Okay, since you're the only reporter, will close as WONTFIX for F12.


Note You need to log in before you can comment on or make changes to this bug.