Bug 520380 - BuildRequires libtnc-devel package which does not exist in Fedora
Summary: BuildRequires libtnc-devel package which does not exist in Fedora
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xsupplicant
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 501017
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-31 09:00 UTC by Alex Lancaster
Modified: 2010-01-21 01:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-21 01:07:55 UTC


Attachments (Terms of Use)

Description Alex Lancaster 2009-08-31 09:00:19 UTC
This causes the build to fail with:

DEBUG util.py:256:  No Package Found for libtnc-devel

full log:

http://koji.fedoraproject.org/koji/getfile?taskID=1635640&name=root.log

and because xsupplicant depends on openssl, this package is currently causing broken deps in rawhide:

	xsupplicant-1.2.8-10.fc11.i586 requires libcrypto.so.8
	xsupplicant-1.2.8-10.fc11.i586 requires libssl.so.8


http://koji.fedoraproject.org/mash/rawhide-20090830/logs/depcheck

Is there a package in review for the missing dep?  If so, this package should not depend on it until such time as it has passed review and is rawhide.  I could not find a package called libtnc or libtnc-devel

Comment 1 Alex Lancaster 2009-08-31 09:04:10 UTC
Ah, I found it: bug #501017.  I guess the CVS was bumped, but the openssl rebuild came along before the review had a chance to be finished.

Comment 2 Bug Zapper 2009-11-16 11:51:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Tom "spot" Callaway 2010-01-21 01:07:55 UTC
libtnc has been in Fedora for some time now.


Note You need to log in before you can comment on or make changes to this bug.