Bug 520402 - no mic input on thinkpad t61
Summary: no mic input on thinkpad t61
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F12Blocker, F12FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2009-08-31 10:56 UTC by Chris Ward
Modified: 2010-06-02 12:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 598931 (view as bug list)
Environment:
Last Closed: 2009-09-09 21:04:32 UTC


Attachments (Terms of Use)
volume control input tab (156.09 KB, image/jpeg)
2009-09-01 15:53 UTC, Chris Ward
no flags Details
volume control hardware tab (152.15 KB, image/jpeg)
2009-09-01 15:56 UTC, Chris Ward
no flags Details
pacmd output (16.68 KB, text/plain)
2009-09-02 15:32 UTC, Chris Ward
no flags Details
amixer (broken config) (3.43 KB, text/plain)
2009-09-02 15:32 UTC, Chris Ward
no flags Details
amixer (working config) (3.43 KB, text/plain)
2009-09-02 15:33 UTC, Chris Ward
no flags Details

Description Chris Ward 2009-08-31 10:56:50 UTC
Description of problem:

I'm running the latest F12 rawhide bits and my sound works but the Mic is not being picked up for some reason. Everything works just fine though in my F11 install; on the same system. Both F11 and F12 are bare-metal installs


Version-Release number of selected component (if applicable):
uname -a
Linux cward.englab.brq.redhat.com 2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 #1 SMP Tue Aug 11 21:00:45 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

rpm -qa pulseaudio
pulseaudio-0.9.16-11.test6.fc12.x86_64

rpm -qa alsa\*
alsa-utils-1.0.20-4.fc12.x86_64
alsa-plugins-pulseaudio-1.0.20-5.fc12.i686
alsa-lib-1.0.20-2.fc12.x86_64
alsa-lib-1.0.20-2.fc12.i686
alsa-plugins-pulseaudio-1.0.20-5.fc12.x86_64


lsmod |grep hda
snd_hda_codec_analog    78528  1 
snd_hda_intel          31528  3 
snd_hda_codec          80448  2 snd_hda_codec_analog,snd_hda_intel
snd_hwdep               9792  1 snd_hda_codec
snd_pcm                90360  3 snd_hda_intel,snd_hda_codec
snd                    74776  11 snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc         10464  2 snd_hda_intel,snd_pcm


Let me know what else i can provide to debug this issue.

Comment 1 Lennart Poettering 2009-08-31 18:13:30 UTC
Please use "gnome-volume-control" and select which input should be used for recording.

Comment 2 Chris Ward 2009-09-01 09:43:17 UTC
I appreciate the response. I have only one input mic and it is selected.

Comment 3 Lennart Poettering 2009-09-01 15:28:39 UTC
Are you sure? 

The mic selection drop-down menu is not shown at all if you only have exactly one mic port on a specific sound card. Which makes your comment a bit strange? How can you say something is selected that is not shown? Could you please attacha screenshot?

Comment 4 Chris Ward 2009-09-01 15:53:10 UTC
Created attachment 359414 [details]
volume control input tab

input tab. 1 of 1 option selected.

rpm -q --whatprovides `which gnome-volume-control`
gnome-media-2.27.90.fix-1.fc12.x86_64

Comment 5 Chris Ward 2009-09-01 15:56:34 UTC
Created attachment 359415 [details]
volume control hardware tab

here's the hardware tab, 1 output / 1 input.

Comment 6 Chris Ward 2009-09-01 15:57:18 UTC
Let me know if i've filed this under the wrong component; if gnome-media is where the problem is by chance

Comment 7 Matthias Clasen 2009-09-02 14:11:58 UTC
I can confirm this. I have a t61, and I have 'Analog Stereo Duplex' selected on the hardware tab and 'internal audio analog stereo' on the input tab. Tapping next to the microphone shows no response at all on the input level meter.

Comment 8 Chris Ward 2009-09-02 14:57:47 UTC
Thanks for the confirmation. I hope this issue gets fixed relatively quickly; i need my mic :) I'm still confused about comment #3 though, why it seems like the UI i'm looking at is different from the one Lennart is looking at.

Comment 9 Lennart Poettering 2009-09-02 15:10:02 UTC
(In reply to comment #8)
> Thanks for the confirmation. I hope this issue gets fixed relatively quickly; i
> need my mic :) I'm still confused about comment #3 though, why it seems like
> the UI i'm looking at is different from the one Lennart is looking at.  

Nah, your input tab shows no dropdown for selecting the input. WHich is expected if you only have a single input.

Could you please do a "alsactl init", then please attach the output of "pacmd ls" and "amixer -c0" here. Then, please play around with "alsamixer -c0" and try to enable the mic input by some means. Then, please do another "alsamixer -c0". This should tell us which control you changed.

This is most likely just a mixer initialization issue, so we need to figure out what exactly gets misinitialized.

Comment 10 Chris Ward 2009-09-02 15:31:42 UTC
I have to say i have no idea what i'm doing here, but i got it working. I'm going to restart and see if it still works... and if it's broken, try to reproduce the fix again. But in the mean time...i'm spill the beans about what i know. Basically, it seems the following turned things on.

amixer -c1 cset name='Capture Switch',index=1 values=on,on

The only difference between the amixer output though from when it wasn't working to when it was ...

[cward@cward ~]# diff amixer.out*
52,53c52,53
<   Front Left: Capture 45 [83%] [9.00dB] [on]
<   Front Right: Capture 45 [83%] [9.00dB] [on]
---
>   Front Left: Capture 54 [100%] [22.50dB] [on]
>   Front Right: Capture 54 [100%] [22.50dB] [on]

I'll attach all the relevant output.

Comment 11 Chris Ward 2009-09-02 15:32:23 UTC
Created attachment 359550 [details]
pacmd output

Comment 12 Chris Ward 2009-09-02 15:32:49 UTC
Created attachment 359551 [details]
amixer (broken config)

Comment 13 Chris Ward 2009-09-02 15:33:17 UTC
Created attachment 359552 [details]
amixer (working config)

Comment 14 Chris Ward 2009-09-02 15:40:21 UTC
Jumped the gun, obviously. Restarted, tried the same command and mic isn't working... continue the debug

Comment 15 Chris Ward 2009-09-02 15:48:24 UTC
okay, so the magic wasn't in the random command i issued (probably badly anyway) but it was with the initial `alsactrl init`

I restarted again and checked that mic wasn't working. Then i issued only alsactrl init and checked again. It's working. I recorded a test file to be sure. Works fine and dandy...

Comment 16 Chris Ward 2009-09-02 15:56:37 UTC
Lennart, final conclusion for the day. diff between amixer out BAD and WORKING (after `alsactrl init` only).

...
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Mic' 'Internal Mic' 'Mix' 'Docking-Station'
  Item0: 'Mic'
82c82
<   Item0: 'Mic'
---
>   Item0: 'Internal Mic'

So 'Mic' is not working but when Item0 is 'Internal Mic' it is, apparently.

Comment 17 Lennart Poettering 2009-09-03 02:52:03 UTC
Ah, nice. This is very helpful!

Could you please grab this file:

http://git.0pointer.de/?p=pulseaudio.git;a=blob_plain;f=src/modules/alsa/mixer/paths/analog-input.conf.common;h=87af38b3ed57a93c118c0268eb451ee0ba6fdfb2;hb=8cd635bc614834c13d0f1c586d472b4a52b98664

and stick it into /usr/share/pulseaudio/alsa-mixer/paths/analog-input.conf.common?

Then, please restart PA (try pulseaudio -k). Now you should have the input dropdown menu populated and can easily switch between the internal mike and the one you can plug in.

The fix is now in PA git, will enter rawhide as soon as I do another upload.

Comment 18 Chris Ward 2009-09-03 06:50:22 UTC
Yup. Works. Will my selection of the preferred mic save as default? i guess I'll see when i restart next...

Comment 19 Lennart Poettering 2009-09-03 14:49:50 UTC
Yes, it will be saved. If it isn't it's a bug.

Comment 20 Chris Ward 2009-09-09 07:59:38 UTC
I'm running pulseaudio-0.9.16-13.test7.fc12.x86_64 and mic isn't working at startup still. I have to run alasctrl init.

Same symptom. There's only one option available in the sound config 

Let me know what other info u need / things i can try

Comment 21 Chris Ward 2009-09-09 08:25:48 UTC
Seems the file provided in comment #17 which i had installed has been reset back to it original state (must have done so during last update). When updating the file again to the one provide in comment #17, things work as expected when i load gnome.

Comment 22 Lennart Poettering 2009-09-09 21:04:32 UTC
So will close this again.

The file is not yet updated in the PA version in rawhide, but is upstream. As soon as I upload a new snapshot this will be fixed inr awhide.


Note You need to log in before you can comment on or make changes to this bug.