Bug 520426 - some dependencies are ignored
Summary: some dependencies are ignored
Keywords:
Status: CLOSED DUPLICATE of bug 223642
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-31 13:09 UTC by Stepan Kasal
Modified: 2009-09-02 12:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-01 06:07:55 UTC


Attachments (Terms of Use)

Description Stepan Kasal 2009-08-31 13:09:40 UTC
Description of problem:
"rpm -e" seems to ignore file dependencies, for example
  rpm -e --test mkinitrd
reports no problem, and indeed "rpm -e mkinitrd" succeeds, leaving package "kernel" win an unsatisfied dependency.

I tried "rm /var/lib/rpm/__*" and "rpm --rebuilddb" but it didn't help

Version-Release number of selected component (if applicable):
rpm-4.7.1-4.fc12.i686

How reproducible:
always

Comment 1 Panu Matilainen 2009-09-01 06:07:55 UTC
The kernel only has Requires(pre): dependencies to mkinitrd which to rpm means mkinitrd is not needed after installation. That verify complains about it is a bug in verify (and this is a dupe)

*** This bug has been marked as a duplicate of bug 223642 ***

Comment 2 Panu Matilainen 2009-09-01 06:24:47 UTC
The other bug here is that the kernel is missing at least one scriptlet dependency:
   Requires(preun): /sbin/new-kernel-pkg

Comment 3 Stepan Kasal 2009-09-02 12:23:23 UTC
(In reply to comment #1)
> The kernel only has Requires(pre): dependencies to mkinitrd which to rpm means

ouch, got trapped again.  The "rpm -qR" output is really confusing.
Is there a way to list the requires with the corresponding flags?

(In reply to comment #2)
> The other bug here is that the kernel is missing at least one scriptlet
> dependency:
>    Requires(preun): /sbin/new-kernel-pkg  

Filed separately as bug 520788.


Note You need to log in before you can comment on or make changes to this bug.