Bug 520453 - udev : fix retry-loop in rename_netif() code
Summary: udev : fix retry-loop in rename_netif() code
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: udev
Version: 5.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-31 14:46 UTC by Olivier Fourdan
Modified: 2018-11-14 20:07 UTC (History)
7 users (show)

Fixed In Version: udev-095-14.22.el5
Doc Type: Bug Fix
Doc Text:
Prior to this update, renaming a network device with udev rules could fail. This was caused by a faulty retry-loop in the code. With this update, renaming a network device works as expected.
Clone Of:
Environment:
Last Closed: 2011-01-13 22:59:56 UTC


Attachments (Terms of Use)
Patch for udev-095 (1.04 KB, patch)
2009-08-31 14:48 UTC, Olivier Fourdan
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0073 normal SHIPPED_LIVE udev bug fix and enhancement update 2011-01-12 17:22:05 UTC

Description Olivier Fourdan 2009-08-31 14:46:40 UTC
Description of problem:

When using a udev rule to rename a network interface, udev fails to find the device.

Version-Release number of selected component (if applicable):

udev-095-14.21

How reproducible:

50% of the time

Steps to Reproduce:

1. Create a udev rule file to set the name of an network interface:
   SUBSYSTEM=="net", ACTION=="add", KERNEL=="eth*", ID=="$PCIBUSID", NAME="ethX"
2. Reboot the system

Actual results:

rename_netif: No such device.   

Expected results:

ethX is created

Additional info:

This was fixed upstream with git commit ca714ef7:

  http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=ca714ef7

Similar patch for udev-095 attached.

Comment 1 Olivier Fourdan 2009-08-31 14:48:06 UTC
Created attachment 359271 [details]
Patch for udev-095

Comment 5 RHEL Product and Program Management 2009-11-06 19:23:49 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 6 Tom Marshall 2010-04-26 20:06:31 UTC
I just tracked down an issue on the systems that we ship to a manifestation of this bug.  Please consider adding this patch to the next release.

Comment 7 Mark Wu 2010-05-26 13:44:30 UTC
We have found two customer hit this bug,  so hope it could be fixed in RHEL 5.6.

Comment 11 Martin Prpič 2010-12-06 14:13:32 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, renaming a network device with udev rules could fail. This was caused by a faulty retry-loop in the code. With this update, renaming a network device works as expected.

Comment 13 errata-xmlrpc 2011-01-13 22:59:56 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0073.html


Note You need to log in before you can comment on or make changes to this bug.