Bug 520466 - Possible indirect dependency conflict with samba3x Supplementary packages
Summary: Possible indirect dependency conflict with samba3x Supplementary packages
Keywords:
Status: CLOSED DUPLICATE of bug 555654
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba3x
Version: 5.4
Hardware: i386
OS: Linux
low
low
Target Milestone: beta
: ---
Assignee: Guenther Deschner
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks: 654252
TreeView+ depends on / blocked
 
Reported: 2009-08-31 15:34 UTC by Marian Ganisin
Modified: 2010-11-17 10:48 UTC (History)
6 users (show)

Fixed In Version: samba3x-3.3.8-0.50.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-04 14:46:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2010:0207 normal SHIPPED_LIVE redhat-release enhancement update 2010-03-29 12:28:07 UTC

Description Marian Ganisin 2009-08-31 15:34:53 UTC
Description of problem:
Sun java plugin rpm package from supplementary set requires /usr/lib/mozilla/plugins directory. This dir is provided by several packages (xulrunner for example). If there is no such package installed, yum selects kdebase by default, it has dependency to samba-common. samba-common package is in conflict samba3x packages placed in supplementary. This situation causes dependency error, when installing all supplementary packages (actually when installing java sun plugin and samba3x packages)

Version-Release number of selected component (if applicable):
RHEL5.4-Server-RC-3.0
RHEL5.4-Server-Supplementary-RC-3.0

Also x86_64 architecture is affected, same behavior on Client and Server.

How reproducible:
1. Install basic system, ensure there is no package providing /usr/lib/mozilla/plugins,
2. use yum to install all supplementary packages (configure repo or use yum localinstall)

Comment 1 Brock Organ 2009-08-31 15:43:34 UTC
The impact for this bug is that depending on which packages selected as part of the RHEL install, the samba3x packages on the supplementary CDs might not install due to package dependency errors ...

Comment 3 Daniel Mach 2009-09-01 13:06:08 UTC
What's the proposed solution?
I'd prefer a release note, if possible.

Comment 4 Marian Ganisin 2009-10-29 13:31:59 UTC
I don't see any objection from QA point of view against release note.

Comment 5 Daniel Mach 2009-10-29 13:44:58 UTC
Ok, let's do a release note.

Comment 7 Pavel Holica 2009-12-15 10:29:17 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
* cause:
Installating java-1.6.0-sun-plugin and samba3x while not having xulrunner installed.

* consequence:
samba3x conflicts with samba-common (due to kdebase dependencies).
This causes, that the yum transaction cannot be completed successfully.

* workaround:
install xulrunner before (or while) installing java-1.6.0-sun-plugin.

* result:
both java-1.6.0-sun-plugin and samba3x are installed, but you can't install kdebase (that includes any KDE app) after doing this.

Comment 8 Pavel Holica 2009-12-15 10:42:15 UTC
Technical note updated. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,5 +1,5 @@
 * cause:
-Installating java-1.6.0-sun-plugin and samba3x while not having xulrunner installed.
+Installing java-1.6.0-sun-plugin and samba3x while not having xulrunner installed.
 
 * consequence:
 samba3x conflicts with samba-common (due to kdebase dependencies).

Comment 9 Pavel Holica 2009-12-15 10:43:43 UTC
This is proposal of release note.

Comment 11 Alexander Todorov 2010-01-14 13:03:09 UTC
Daniel,
are there any code changes for this or it's only release note? If release note only then we're safe to move to verified.

Comment 12 Daniel Mach 2010-01-14 13:12:14 UTC
Alex,
I do not know about any code changes.
The only change is that samba3x moved from Supplementary to Client and Server.
I'm ok with the release note.

Comment 13 Alexander Todorov 2010-01-14 14:07:11 UTC
OK. Moving to VERIFIED then.

Comment 14 Daniel Mach 2010-01-19 15:36:02 UTC
Things have changed, samba3x moved from Supplementary to Client/Server.
We'll need to fix this issue, a release note is not enough.

Reassigning to samba3x component.

Comment 17 Marian Ganisin 2010-02-04 14:43:16 UTC
Deleted Technical Notes Contents.

Old Contents:
* cause:
Installing java-1.6.0-sun-plugin and samba3x while not having xulrunner installed.

* consequence:
samba3x conflicts with samba-common (due to kdebase dependencies).
This causes, that the yum transaction cannot be completed successfully.

* workaround:
install xulrunner before (or while) installing java-1.6.0-sun-plugin.

* result:
both java-1.6.0-sun-plugin and samba3x are installed, but you can't install kdebase (that includes any KDE app) after doing this.

Comment 18 Marian Ganisin 2010-02-04 14:46:49 UTC

*** This bug has been marked as a duplicate of bug 555654 ***


Note You need to log in before you can comment on or make changes to this bug.