Bug 52051 - no access to tty (Inappropriate ioctl for device).
Summary: no access to tty (Inappropriate ioctl for device).
Status: CLOSED DUPLICATE of bug 51044
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mingetty
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-19 20:07 UTC by Anush
Modified: 2007-04-18 16:36 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-08-22 19:11:02 UTC


Attachments (Terms of Use)

Description Anush 2001-08-19 20:07:03 UTC
Description of Problem:

When i log into my system(Roswell, with ext3 filesystem) after a reboot, at
every first login I get the following error. I dont know if it is a
permissions issue or something with the shell. 

Version-Release number of selected component (if applicable):


How Reproducible: Everytime


Steps to Reproduce:

1.Reboot Roswell System
2.First login on terminal gives error
3.Later logins are fine

Actual Results:

sekrishn-dsl5 login: anush1
Password:
Last login: Sun Aug 19 12:07:12 on tty1
Warning: no access to tty (Inappropriate ioctl for device).
Thus no job control in this shell.
[anush1@sekrishn-dsl5 ~]$


Expected Results:

Additional Information:
sekrishn-dsl5 login: anush1
Password:
Last login: Sun Aug 19 12:07:12 on tty1
[anush1@sekrishn-dsl5 ~]$	


All programs are stock redhat roswell. I just upgraded galeon.

Comment 1 Glen Foster 2001-08-20 19:17:37 UTC
We (Red Hat) really need to fix this before next release.

Comment 2 Bill Nottingham 2001-08-21 14:29:10 UTC
What version of util-linux is installed - what happens if you upgrade to the
latest version?

Comment 3 Anush 2001-08-22 07:17:08 UTC
The current version of util-linux I am using is the one that ships with Roswell,
version 2.11f-5.

I downloaded the latest version 2.11h from kernel.org, but it warned me of
certain complications in my system beyond my knowledge hence I didnot upgrade
the util-linux. I will be glad to try a rpm for roswell if someone can provide
the same.

Comment 4 Florian La Roche 2001-08-22 13:08:37 UTC
can you please try a util-linux rpm from either rawhide or from our second
public beta (which is in the same dir as the first one)?

Florian La Roche


Comment 5 Nalin Dahyabhai 2001-08-23 13:59:14 UTC
This appears to be fixed in the latest Raw Hide push, so I'm closing this bug.

*** This bug has been marked as a duplicate of 51044 ***


Note You need to log in before you can comment on or make changes to this bug.