Bug 520536 - No sound from flash
Summary: No sound from flash
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-01 00:11 UTC by Gary Thomas
Modified: 2018-04-11 12:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-05 07:28:17 UTC
Type: ---


Attachments (Terms of Use)

Description Gary Thomas 2009-09-01 00:11:22 UTC
Description of problem:

New Fedora 11 - sound works (effects, saytime, etc), but nothing from
Flash plugin 9.0 r124

Version-Release number of selected component (if applicable):

3.5.2 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matěj Cepl 2009-09-04 14:58:25 UTC
Could we get output of the command

	rpm -qa \*xulrun\* \*firefox\* \*mozilla\* \*flash\* \*plugin\*

(just copy and paste to the command line ... these are real asterisks not just making it bold)

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Gary Thomas 2009-09-04 22:36:40 UTC
Requested data:

# rpm -qa \*xulrun\* \*firefox\* \*mozilla\* \*flash\* \*plugin\*
setroubleshoot-plugins-2.0.18-5.fc11.noarch
gstreamer-plugins-good-0.10.15-4.fc11.i586
gdm-plugin-fingerprint-2.26.1-13.fc11.i586
totem-mozplugin-2.26.3-1.fc11.i586
firefox-3.5.2-2.fc11.i586
gstreamer-plugins-base-0.10.23-3.fc11.i586
alsa-plugins-pulseaudio-1.0.20-2.fc11.i586
plymouth-plugin-label-0.7.0-0.2009.05.15.1.fc11.i586
xulrunner-1.9.1.2-1.fc11.i586
PackageKit-gstreamer-plugin-0.4.9-1.fc11.i586
nspluginwrapper-1.3.0-6.fc11.i586
PackageKit-yum-plugin-0.4.9-1.fc11.i586
java-1.6.0-openjdk-plugin-1.6.0.0-27.b16.fc11.i586
mozilla-filesystem-1.9-4.fc11.i586
xulrunner-devel-1.9.1.2-1.fc11.i586
anaconda-yum-plugins-1.0-4.fc11.noarch
plymouth-plugin-two-step-0.7.0-0.2009.05.15.1.fc11.i586
gstreamer-plugins-flumpegdemux-0.10.15-6.fc11.i586

Note: this is a freshly installed Fedora 11, with updates as of 2009-08-31

Comment 3 Christopher Aillon 2009-09-05 07:28:17 UTC
From the initial comment it is evident what the problem is.  Flash 9 is old and will not work since that was pre-pulseaudio.  Flash 10 has better support for pulseaudio.  If one follows all the steps in http://fedoraproject.org/wiki/Multimedia/Flash it will work.

Anyway, obviously not a bug in firefox.

Comment 4 Gary Thomas 2009-09-05 11:11:22 UTC
When I installed Fedora 11 fresh, I copied/restored my previous
"home" files, including ~/.mozilla (too many stored passwords and
such).  That old plugin came along for the ride :-(

Thanks for the help

Comment 5 Eli Wapniarski 2009-10-02 06:28:43 UTC
I have the same problem.... I get no sound from flash whether I use the 32bit plugin with nspluginwrapper, or the 64bit beta plugin without nspluginwrapper.

I tried to compile and install the libflashsupport library directly from adobe. I did get sound, but it was out of sync.

However, after finding the old

libflashsupport-000-0.5.svn20070904.src.rpm

at

http://download.fedora.redhat.com/pub/fedora/linux/releases/9/Fedora/source/SRPMS/libflashsupport-000-0.5.svn20070904.src.rpm

rebuilt and installed it everything worked fine. I guess the solution for the time being would be to provide the libflashsupport library again. At least until all this gets sorted out.

Comment 6 Eli Wapniarski 2009-10-02 06:30:32 UTC
Oh... I forgot to mention the problem is noted with the latest Firefox release in F11 repository and Flash 10 plugins.

Comment 7 Christopher Aillon 2009-10-02 19:26:18 UTC
Eli, did you follow the steps from the URL in comment 3?  In particular, pay attention to the part about needing to install the 32bit version of alsa-plugins-pulseaudio

Comment 8 Eli Wapniarski 2009-10-02 19:55:36 UTC
Of course.... But, currently, the 32bit issue has become irrelevant since I'm using the 64bit flash plugin with a great deal of success.

The sound issue has been driving me batty.

Comment 9 Eli Wapniarski 2009-10-02 20:01:28 UTC
Oh... I should mention... I'm beginning to suspect that there is some problem with the interaction between nspluginviewer and pulseaudio.... I'm seeing a lot of problems with plugins and multimedia streams... crashes of both Firefox and Konqueror (not a flash issue). But those are to some extent, different issues and I do need to investigate further before I can file bug reports that make some sense.

Comment 10 Eli Wapniarski 2009-10-03 05:35:27 UTC
K... Finally took the time to investigate. And my assumptions were wrong. I believe the crashing that I've run across recently are due to the beta state of the 64bit flash plugin.

However, that still doesn't take away from the problem I had on the 32bit official release.

I really hope we can work this kink out.

If there is anything more that I can do please do not hesitate to ask.

Comment 11 Christopher Aillon 2009-10-05 21:41:45 UTC
File a different bug, then.  Your issue seems different from the reporter's since it works for him, though the symptoms are the same.


Note You need to log in before you can comment on or make changes to this bug.