Bug 520571 - Sound playback on Intel 82801DB-ICH4 stops after a while
Sound playback on Intel 82801DB-ICH4 stops after a while
Status: CLOSED DUPLICATE of bug 506075
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-01 03:38 EDT by Petr Tuma
Modified: 2009-09-04 08:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 08:00:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Tuma 2009-09-01 03:38:39 EDT
Description of problem:

After playing for a while, the audio simply stops working. A log record appears in /var/log/messages:

Aug 28 08:15:11 machine pulseaudio[17033]: alsa-sink.c: Increasing wakeup watermark to 30,00 ms
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294937332 bytes (24347717 ms).
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c: snd_pcm_dump():
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c: Hardware PCM card 0 'Intel 82801DB-ICH4' device 0 subdevice 0
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c: Its setup is:
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   stream       : PLAYBACK
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   access       : MMAP_INTERLEAVED
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   format       : S16_LE
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   subformat    : STD
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   channels     : 2
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   rate         : 44100
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   exact rate   : 44100 (44100/1)
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   msbits       : 16
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   buffer_size  : 16384
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   period_size  : 16384
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   period_time  : 371519
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   tstamp_mode  : ENABLE
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   period_step  : 1
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   avail_min    : 16384
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   period_event : 0
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   start_threshold  : -1
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   stop_threshold   : 1073741824
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   silence_threshold: 0
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   silence_size : 0
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   boundary     : 1073741824
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   appl_ptr     : 9035080
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   hw_ptr       : 9011205
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 462112 bytes (2619 ms).
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c: snd_pcm_dump():
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c: Hardware PCM card 0 'Intel 82801DB-ICH4' device 0 subdevice 0
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c: Its setup is:
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   stream       : PLAYBACK
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   access       : MMAP_INTERLEAVED
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   format       : S16_LE
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   subformat    : STD
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   channels     : 2
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   rate         : 44100
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   exact rate   : 44100 (44100/1)
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   msbits       : 16
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   buffer_size  : 16384
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   period_size  : 16384
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   period_time  : 371519
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   tstamp_mode  : ENABLE
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   period_step  : 1
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   avail_min    : 16384
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   period_event : 0
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   start_threshold  : -1
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   stop_threshold   : 1073741824
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   silence_threshold: 0
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   silence_size : 0
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   boundary     : 1073741824
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   appl_ptr     : 9127690
Aug 28 08:15:35 machine pulseaudio[17033]: alsa-util.c:   hw_ptr       : 9012162
Aug 28 08:15:40 machine pulseaudio[17033]: ratelimit.c: 6483 events suppressed
Aug 28 08:15:44 machine pulseaudio[17033]: alsa-sink.c: Increasing wakeup watermark to 40,00 ms

Version-Release number of selected component (if applicable):

alsa-utils-1.0.20-3.fc11.i586
alsa-plugins-pulseaudio-1.0.20-2.fc11.i586
alsa-lib-1.0.20-1.fc11.i586

The bug started to appear after installing the new kernel:

kernel-2.6.29.6-217.2.16.fc11

How reproducible:

Just have an application (e.g. xine) play for a while.
The sound will disappear eventually (usually it takes 5-10 minutes).
Comment 1 Petr Tuma 2009-09-04 08:00:43 EDT

*** This bug has been marked as a duplicate of bug 506075 ***

Note You need to log in before you can comment on or make changes to this bug.