Bug 520583 - system-config-services crash on f12 alpha xfce spin
Summary: system-config-services crash on f12 alpha xfce spin
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-services
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-01 08:46 UTC by phil
Modified: 2009-11-18 20:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-18 20:37:34 UTC


Attachments (Terms of Use)

Description phil 2009-09-01 08:46:50 UTC
Description of problem:
system-config-services wont run on the F12 Alpha xfce spin


Version-Release number of selected component (if applicable):
system-config-services-0.99.38-1.fc12.noarch

How reproducible:
every time

Steps to Reproduce:
1.install f12 alpha xfce spin
2.login 
3.try to run system-config-services
  
Actual results:
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 951, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 909, in __init__
    serviceherders = self.serviceherders)
  File "/usr/bin/system-config-services", line 765, in __init__
    self.servicesList = GUIServicesList (xml = self.xml, serviceherders = serviceherders)
  File "/usr/bin/system-config-services", line 467, in __init__
    if herder.ready:
  File "/usr/lib/python2.6/site-packages/scservices/dbus/proxy/serviceherders.py", line 64, in ready
    return self.herder_interface.is_ready ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.


Expected results:
system-config-services gui to run

Additional info:
uname -a
Linux aspire.one 2.6.31-0.190.rc8.fc12.i686 #1 SMP Fri Aug 28 19:07:13 EDT 2009 i686 i686 i386 GNU/Linux

hardware is aspire one a150, smolt profile >> 
http://www.smolts.org/client/show/pub_7739cc3d-c22a-4bf9-a2dd-33c7d37a5b0

if you need any more info don't hesitate to ask

Comment 1 Nils Philippsen 2009-09-02 09:43:10 UTC
I could reproduce this with 0.99.39 on my Rawhide virtual machine. I found that SELinux wouldn't let the application attach to the system bus, which was likely due to some mislabelled files. After I relabelled the filesystem, I didn't get these errors anymore and the application worked correctly.

Comment 2 phil 2009-09-02 23:10:20 UTC
confirmed no longer a problem in 0.99.39-1 :)

thanks nils

Comment 3 phil 2009-09-07 21:01:15 UTC
sorry to be a pest but it's re-surfaced, i've tried re-labelling with system-config-selinux but it's making no difference, only changes from working to not working are just updates, those which may have caused them are namely

Sep 02 23:36:17 Updated: selinux-policy-3.6.30-1.fc12.noarch
Sep 02 23:37:54 Updated: selinux-policy-targeted-3.6.30-1.fc12.noarch
Sep 04 08:57:12 Updated: selinux-policy-3.6.30-2.fc12.noarch
Sep 04 08:58:31 Updated: selinux-policy-targeted-3.6.30-2.fc12.noarch
Sep 04 08:59:09 Installed: kernel-2.6.31-0.199.rc8.git2.fc12.i686
Sep 07 16:14:46 Installed: kernel-2.6.31-0.204.rc9.fc12.i686

any help you can offer is most welcome

phil

Comment 4 Bug Zapper 2009-11-16 11:53:07 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.