Bug 520591 - Sectool option --use-dbus throws traceback on F12 rawhide
Summary: Sectool option --use-dbus throws traceback on F12 rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: sectool
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Maros Barabas
QA Contact: Eduard Benes
URL:
Whiteboard:
: 520638 (view as bug list)
Depends On:
Blocks: RHEL6Sectool
TreeView+ depends on / blocked
 
Reported: 2009-09-01 10:09 UTC by Eduard Benes
Modified: 2009-09-09 14:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-09 14:30:33 UTC


Attachments (Terms of Use)

Description Eduard Benes 2009-09-01 10:09:17 UTC
Description of problem:
Running the sectool with --use-dbus option on F12 rawhide system produces following traceback. On updated F11 system it works as expected using the same version of sectool.

# sectool --version
sectool 0.9.4
# rpm -q sectool
sectool-0.9.4-1.fc11.i586
# rpm -q fedora-release
fedora-release-11.91-3.noarch

# sectool --use-dbus --list
Traceback (most recent call last):
  File "/usr/sbin/sectool", line 418, in run
    bus = DBusCaller()
  File "/usr/sbin/sectool", line 330, in __init__
    self.dbus_action_object = self.bus.get_object ("org.fedoraproject.sectool.mechanism", "/org/fedoraproject/sectool/object")
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1

# rpm -qf /usr/lib/python2.6/site-packages/dbus/bus.py
dbus-python-0.83.0-6.fc12.i686

Current result:
traceback

Expected result:
no traceback and list of tests (in this example)

Comment 1 Maros Barabas 2009-09-01 11:57:46 UTC
Please try execute same command with selinux in permissive mode. Thanks

Comment 2 Eduard Benes 2009-09-01 12:16:33 UTC
I'm not aware of changing anything specific, but this time I get following traceback in both permissive and enforcing mode: 

<snip>
# setenforce 0
# getenforce 
Permissive
# sectool --use-dbus --list
Traceback (most recent call last):
  File "/usr/sbin/sectool", line 437, in run
    else: raise e
DBusException: org.freedesktop.PolicyKit1.Error.Failed: Action org.fedoraproject.sectool.listtests is not registered
Waiting few seconds for thread timeout..
</snip>

Comment 3 Maros Barabas 2009-09-03 11:56:20 UTC
*** Bug 520638 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.