Bug 5206 - sndconfig doesn't initialize ESS 1868 properly - freezes computer
sndconfig doesn't initialize ESS 1868 properly - freezes computer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-18 14:00 EDT by Trond Eivind Glomsrød
Modified: 2014-03-16 22:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-08 14:59:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trond Eivind Glomsrød 1999-09-18 14:00:47 EDT
sndconfig recognizes the ESS 1868 (A ISA pnp card), but
when it loads the modules, the computer freezes
(consoleswitch works, but doing anything in any prompt
doesn't return)
Comment 1 Bill Nottingham 1999-09-18 14:44:59 EDT
That's not good. Any chance you could run a debugging version
under gdb and see where this is happening?

Does it happen if you just do:
modprobe sb io=whatever, etc. from the command line, or if you
run

a) pnpdump -c
b) isapnp /etc/isapnp.conf?
Comment 2 Trond Eivind Glomsrød 1999-09-18 16:49:59 EDT
"pnpdump -c" hangs indefitely, with this output (note that this,
unlike sndconfig, can be terminated by ctrl-c. You can't do much
until you've done that, though):

# Compiler flags: -DREALTIME -DNEEDSETSCHEDULER -DABORT_ONRESERR
#
# Trying port address 0203
# Board 1 has serial identifier 27 ff ff ff ff 68 18 73 16
# Board 2 has serial identifier a4 00 00 00 44 88 16 75 06

# (DEBUG)
(READPORT 0x0203)
(ISOLATE PRESERVE)
(IDENTIFY *)
(VERBOSITY 2)
(CONFLICT (IO FATAL)(IRQ FATAL)(DMA FATAL)(MEM FATAL)) # or WARNING

When I use my old isapnp.conf-file (and modprobe) I get sound, and
the system doesn't lock up. The file was not generated by sndconfig
earlier - I remember using pnpdump, though.
Comment 3 Bill Nottingham 1999-09-18 17:00:59 EDT
Is the readport different in the working isapnp.conf?
Comment 4 Trond Eivind Glomsrød 1999-09-18 17:06:59 EDT
"pnpdump -c" hangs indefitely, with this output (note that this,
unlike sndconfig, can be terminated by ctrl-c. You can't do much
until you've done that, though):

# Compiler flags: -DREALTIME -DNEEDSETSCHEDULER -DABORT_ONRESERR
#
# Trying port address 0203
# Board 1 has serial identifier 27 ff ff ff ff 68 18 73 16
# Board 2 has serial identifier a4 00 00 00 44 88 16 75 06

# (DEBUG)
(READPORT 0x0203)
(ISOLATE PRESERVE)
(IDENTIFY *)
(VERBOSITY 2)
(CONFLICT (IO FATAL)(IRQ FATAL)(DMA FATAL)(MEM FATAL)) # or WARNING

When I use my old isapnp.conf-file (and modprobe) I get sound, and
the system doesn't lock up. The file was not generated by sndconfig
earlier - I remember using pnpdump, though.
Comment 5 Trond Eivind Glomsrød 1999-09-18 17:07:59 EDT
The working file looks like this:

(ISOLATE)
(IDENTIFY *)
(CONFIGURE ESS1868/-1 (LD 1
(IO 0 (BASE 0x0220))
(IO 1 (BASE 0x0388))
(IO 2 (BASE 0x0330))
(DMA 0 (CHANNEL 1))
(INT 0 (IRQ 5 (MODE +E)))
(ACT Y)
))
(CONFIGURE ASU1688/68 (LD 0
#         Number of IO addresses required: 4
(IO 0 (BASE 0x0100))
#     IRQ 3, 4, 5, 9, 10, 11, 12 or 15.
#         High true, edge sensitive interrupt
(INT 0 (IRQ 3 (MODE +E)))
#     *** ERROR *** No IRQ specified!
(ACT Y)
))

(WAITFORKEY)

I don't see any readport at all
Comment 6 Bill Nottingham 1999-09-18 17:22:59 EDT
There will be a new sndconfig (appearing shortly, 0.37-3), that
makes pnpdump run outside of newt, so you should be able to kill it.
It probably won't actually configure the card, though.

What sort of motherboard/chipset/BIOS do you have?
Comment 7 Trond Eivind Glomsrød 1999-09-19 06:49:59 EDT
The motherboard is AI5TV-V8-0530.  It has an Award 4.51PG BIOS, with
Award Plug and Play Bios Extension v1.0a
(it is a P200MMX-computer which I only have access to during weekends)
Comment 8 Bill Nottingham 1999-09-19 14:45:59 EDT
What kernel are you running?
Comment 9 Trond Eivind Glomsrød 1999-09-19 15:25:59 EDT
2.2.12-10, pentium version - the default installed (lorax, 0914).
FWIW, I compiled a custom kernel (from the same sources) and it
behaves in the samme manner.

It looks like the working file initialises the board on 0x100, which
is below 0x203 where pnpdump starts looking?
Comment 10 Bill Nottingham 1999-09-20 11:07:59 EDT
Actually, the 0x100 is just the first port for the second
card (modem?)
Comment 11 Bill Nottingham 1999-09-23 15:23:59 EDT
Should be fixed with sndconfig-0.37-4, isapnptools-1.18b-2.

Note You need to log in before you can comment on or make changes to this bug.