Bug 52060 - (SiS630) Xconfigurator segmentation fault
(SiS630) Xconfigurator segmentation fault
Status: CLOSED DUPLICATE of bug 44851
Product: Red Hat Public Beta
Classification: Retired
Component: Xconfigurator (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-19 21:28 EDT by Warren Togami
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-20 15:17:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2001-08-19 21:28:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
After PCI Probe correctly detects SiS630 video chipset, Xconfigurator 
crashes with segmentation fault on the next screen.

Version-Release number of selected component (if applicable):
Both 4.9.33 (Roswell) and 4.9.34-1 (Rawhide)

How reproducible:
Always

Steps to Reproduce:
1. Run Xconfigurator.
2. Hit enter twice.
	

Actual Results:  Segmentation fault


Expected Results:  No crash...

Additional info:

Brand new machine
Athlon 1.2GHz Thunderbird 200fsb XIA stepping
Asus A7VS-VM motherboard with integrated SiS630 video chipset
http://www.asus.com.tw/products/Motherboard/socketa/a7s-vm/index.html
512MB PC133 2-2-2 ECC Crucial

SiS730 is what they call the motherboard chipset, but the graphics is 
SiS630.

This occurs in the fresh install of Roswell.  Also tried latest 
Xconfigurator package from Rawhide Xconfigurator-4.9.34-1.i386.rpm.

[root@localhost root]# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 730 Host (rev 02)
00:00.1 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:01.0 ISA bridge: Silicon Integrated Systems [SiS] 85C503/5513
00:01.2 USB Controller: Silicon Integrated Systems [SiS] 7001 (rev 07)
00:01.3 USB Controller: Silicon Integrated Systems [SiS] 7001 (rev 07)
00:01.4 Multimedia audio controller: Silicon Integrated Systems [SiS] SiS 
PCI Au
dio Accelerator (rev 02)
00:02.0 PCI bridge: Silicon Integrated Systems [SiS] 5591/5592 AGP
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 
10)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] SiS630 
GUI A
ccelerator+3D (rev 31)

[root@localhost root]# lspci -n 
00:00.0 Class 0600: 1039:0730 (rev 02)
00:00.1 Class 0101: 1039:5513 (rev d0)
00:01.0 Class 0601: 1039:0008
00:01.2 Class 0c03: 1039:7001 (rev 07)
00:01.3 Class 0c03: 1039:7001 (rev 07)
00:01.4 Class 0401: 1039:7018 (rev 02)
00:02.0 Class 0604: 1039:0001
00:09.0 Class 0200: 10ec:8139 (rev 10)
01:00.0 Class 0300: 1039:6300 (rev 31)
Comment 1 Glen Foster 2001-08-20 15:17:43 EDT
We (Red Hat) really need to fix this before next release.
Comment 2 Mike A. Harris 2001-08-23 11:21:57 EDT

*** This bug has been marked as a duplicate of 44851 ***

Note You need to log in before you can comment on or make changes to this bug.