Bug 520614 - Error when comparing timestamps
Summary: Error when comparing timestamps
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-01 13:01 UTC by Ben Boeckel
Modified: 2014-01-21 23:11 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 21:52:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Boeckel 2009-09-01 13:01:33 UTC
Description of problem:
KPackageKit just started getting the following backtrace when updating metadata:

Traceback (most recent call last):
File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 1411, in refresh_cache
self.yumbase.repos.populateSack(which=[repo.id], mdtype='metadata', cacheonly=1)
File "/usr/lib/python2.6/site-packages/yum/repos.py", line 260, in populateSack
sack.populate(repo, mdtype, callback, cacheonly)
File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 162, in populate
if self._check_db_version(repo, mydbtype):
File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 220, in _check_db_version
return repo._check_db_version(mdtype)
File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1178, in _check_db_version
repoXML = self.repoXML
File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1342, in 
repoXML = property(fget=lambda self: self._getRepoXML(),
File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1334, in _getRepoXML
self._loadRepoXML(text=self)
File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1324, in _loadRepoXML
return self._groupLoadRepoXML(text, ["primary"])
File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1307, in _groupLoadRepoXML
if self._commonLoadRepoXML(text):
File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1171, in _commonLoadRepoXML
if not self._groupCheckDataMDNewer():
File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1052, in _groupCheckDataMDNewer
old_repo_XML.timestamp > self.repoXML.timestamp):
AttributeError: 'NoneType' object has no attribute 'timestamp'

Version-Release number of selected component (if applicable):
kpackagekit-0.4.2-0.fc11.x86_64

Comment 1 Steven M. Parrish 2009-09-01 13:03:58 UTC
Looks like this is an issue with the underlying PackageKit.  Reassigning there.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Richard Hughes 2009-09-01 13:19:34 UTC
It's a backtrace from deep in the internals of yum. Reassigning once more.

Comment 3 seth vidal 2009-09-01 19:16:52 UTC
Can anyone make this happen on yum from rawhide?

Comment 4 James Antill 2009-09-18 16:00:49 UTC
To trigger it you want a repomd.xml file in the repo. cache ... which doesn't parse.
Not sure how the hell this happens, but we probably shouldn't die. Fix posted for approval upstream.

Comment 5 Fedora Update System 2009-09-30 01:39:20 UTC
yum-3.2.24-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2009-10-19 16:45:49 UTC
yum-3.2.24-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-3.2.24-2.fc10

Comment 7 Fedora Update System 2009-11-04 12:06:39 UTC
yum-3.2.24-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.