Bug 520616 - sectool --info NotAtest --use-dbus throws traceback
Summary: sectool --info NotAtest --use-dbus throws traceback
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: sectool
Version: 11
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-01 13:14 UTC by Miroslav Vadkerti
Modified: 2009-09-01 13:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-01 13:55:11 UTC


Attachments (Terms of Use)

Description Miroslav Vadkerti 2009-09-01 13:14:30 UTC
Description of problem:

$ sectool --info NotATest --use-dbus
Traceback (most recent call last):
  File "/usr/sbin/sectool", line 438, in run
    else: raise e
DBusException: org.freedesktop.DBus.Python.tuierrors.SecToolActionError: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/site-packages/slip/dbus/service.py", line 81, in wrapped_method
    retval = method (self, *p, **k)
  File "/usr/libexec/sectool-mechanism.py", line 108, in infotests
    return self.ST_Action( actions.ST_InfoTests, args, file )
  File "/usr/libexec/sectool-mechanism.py", line 84, in ST_Action
    return self.__perform_action( action, options, file )
  File "/usr/libexec/sectool-mechanism.py", line 74, in __perform_action
    action.doAction()
  File "/usr/share/sectool/actions.py", line 107, in doAction
    self.doStuff()
  File "/usr/share/sectool/actions.py", line 488, in doStuff
    self.assert_suite_not_empty( suite )
  File "/usr/share/sectool/actions.py", line 120, in assert_suite_not_empty
    raise tuierrors.SecToolActionError(self.name, _("No matching tests to run"))
SecToolActionError: Error: No matching tests to run

Waiting few seconds for thread timeout..

Version-Release number of selected component (if applicable):
0.9.4-2

How reproducible:
always

Steps to Reproduce:
1. sectool --info NotATest --use-dbus
  
Actual results:
traceback

Expected results:
no traceback

Additional info:
With permissive selinux the result is the same.

Comment 1 Maros Barabas 2009-09-01 13:55:11 UTC
When exception occures in backend side of app. dbus will return exception as well, but except tuierrors.SecToolActionError, dbus will raise DBusException: org.freedesktop.DBus.Python.tuierrors.SecToolActionError. 
Traceback is not a bug, unknown messages are written to stderr with traceback. It could be done by catching all possible exceptions we know about, but it's much more (almost useless) code. If somebody want a fix for this issue, please reopen this bug (fix for all exceptions not only this one).


Note You need to log in before you can comment on or make changes to this bug.