Bug 520640 - GDM periodically hangs
Summary: GDM periodically hangs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-01 14:57 UTC by Shay Zukerman
Modified: 2015-01-14 23:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 04:53:05 UTC


Attachments (Terms of Use)

Description Shay Zukerman 2009-09-01 14:57:41 UTC
Description of problem:
I have been using Fedora for more 1 1/2 years now: FC7, FC9 and now F11.
There were no special problems, until the past week that the GDM unexpectedly hangs; only the mouse is moving and it is impossible to access the machine from the Keyboard.
There's no problem connecting the desktop from another machine via SSH, and that's how I reboot the server.

At the beginning I thought that the source of the problem was VLC or any other Audio player - but today, the machine had stuck when it did not run them, and active window was Firefox.


Version-Release number of selected component (if applicable):


How reproducible:
Impossible

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Output of uname -r: 2.6.29.6-217.2.16.fc11.i686.PAE

Comment 1 Shay Zukerman 2009-09-01 14:59:43 UTC
An information which I forgot to add:
the details of the GDM's package: gdm-2.26.1-13.fc11.i586.

Thanks

Shay

Comment 2 Sergey Rudchenko 2009-09-23 18:33:38 UTC
Thank you for the bug report.

Please provide some steps which lead to the problem.

At what moment it hangs: at logging in or at switching the user?

> How reproducible:
> Impossible

Don't you experience the problem anymore?

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Shay Zukerman 2009-09-24 04:53:05 UTC
Hi

I will begin with the end: the problem was solved by adding: nomodeset to the active kernel's parameter in /boot/grub/grub.conf.

After opening the bug, I kept researching the issue, and found that it only occurred when I used Firefox. 
When I realized the this was the cause of the problem, I looked for an alternative browser and tried "Konqueror" - and the problem had repeated itself.

Finally, I started looking at Fedora's forum and other places and finally had stumbled on this workaround that solved the problem.

Now: could you please send me a short description about this parameter?

Thanks!

Shay


Note You need to log in before you can comment on or make changes to this bug.