Bug 520680 - Installing PHatch causes Firefox to open directories in PHatch instead of Nautilus
Summary: Installing PHatch causes Firefox to open directories in PHatch instead of Nau...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: phatch
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nicoleau Fabien
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-01 19:13 UTC by Russell Harrison
Modified: 2009-11-30 21:06 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-11-30 21:06:26 UTC


Attachments (Terms of Use)

Description Russell Harrison 2009-09-01 19:13:18 UTC
Description of problem:
After installing phatch I'm unable to get Firefox to open a folder in anything else.

Version-Release number of selected component (if applicable):
phatch-0.1.6-4.fc11.i586
firefox-3.5.2-2.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Install phatch package
2. Download something in firefox and save it to disk
3. In the firefox download window right click on a download and select "Open Containing Folder"
  
Actual results:
Phatch is opened.

Expected results:
the folder is opened in nautilus

Additional info:

Comment 1 Nicoleau Fabien 2009-09-02 19:22:54 UTC
Hi, thanks for the report.
It seems that the problem comes from the .desktop file that contain "inode/directory;" in MimeType. Rebuilding the package without this fix the problem, but upstream proposed an other idea : http://lists.alioth.debian.org/pipermail/python-apps-team/2009-May/001535.html but it has no effect for me.
I'm trying to find a better solution than removing inode/directory;

Comment 2 Russell Harrison 2009-09-04 03:43:43 UTC
That's pretty much what I came up with as well.  I tried placing those settings in both my user and global defaults files without improvement before opening the bug.  It almost seems like Firefox is using a different source for its mime data.  xdg-open, gnome-open, etc. seem to pick up the changes properly.

Comment 3 Nicoleau Fabien 2009-09-08 18:28:07 UTC
I think this bu is also related to :
#497710 #508585 and #508667

Comment 4 Nicoleau Fabien 2009-11-29 00:07:01 UTC
It seems ok under F12, with firefox-3.5.5-1 and nautilus-2.28.1-4

Comment 5 Russell Harrison 2009-11-30 15:31:11 UTC
It seems to be working properly in F12 for me as well.

Comment 6 Nicoleau Fabien 2009-11-30 21:06:26 UTC
As the problem was not directly related to phatch, I'm closing the bug.


Note You need to log in before you can comment on or make changes to this bug.