Bug 520715 - nss-softokn dumb trigger tricks for prelink.conf.d
Summary: nss-softokn dumb trigger tricks for prelink.conf.d
Keywords:
Status: CLOSED DUPLICATE of bug 520158
Alias: None
Product: Fedora
Classification: Fedora
Component: nss-softokn
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Elio Maldonado Batiz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-01 21:43 UTC by Warren Togami
Modified: 2009-09-17 04:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 04:17:59 UTC


Attachments (Terms of Use)

Description Warren Togami 2009-09-01 21:43:58 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=515034#c13
I see where the prelink.conf.d triggers were suggested during the nss-softokn package review.  But seriously, this was a bad idea, needlessly adding complication for no benefit.

tibbs is going ahead and adding /etc/prelink.conf.d to the filesystem package.  nss-softokn should just install the file in that directory and not worry about ownership of the directory.

Furthermore this fixes a non-fatal error message during rpm transactions like:
  Cleanup        : nss-softokn-3.12.3.99.3-23.fc12.i686                                                         Non-fatal POSTUN scriptlet failure in rpm package n
warning: %postun(nss-softokn-3.12.3.99.3-23.fc12.i686) scriptlet failed, exit status 1

What to do?
1) Just install the file in the package, own it in %files
2) Do not own the directory.
3) Remove all the related trigger and scriptlet stuff.

Comment 1 Elio Maldonado Batiz 2009-09-01 22:22:13 UTC
See the last comment on Bug 520158 but if there is a better way I am all ears.

Comment 2 Elio Maldonado Batiz 2009-09-17 04:17:59 UTC

*** This bug has been marked as a duplicate of bug 520158 ***


Note You need to log in before you can comment on or make changes to this bug.