Bug 520809 - Samba "map read only" problems
Summary: Samba "map read only" problems
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Simo Sorce
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 13:58 UTC by 260795
Modified: 2009-09-02 15:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 14:09:13 UTC


Attachments (Terms of Use)

Description 260795 2009-09-02 13:58:48 UTC
Description of problem:

Samba setting "map read only = yes" causes problem with read only files.

Version-Release number of selected component (if applicable):

samba-3.3.2-0.33.fc11

How reproducible:

Always

Steps to Reproduce:

1. Add "map read only = yes" to the configuration file
2. Set a file shared by samba as read only from a Windows client
3. Try removing the read only attribute
  
Actual results:

Permission problem errors.

Expected results:

Removal of the read only attribute.

Additional info:

The bug is better described here:

https://bugzilla.samba.org/show_bug.cgi?id=6186

Please consider including the provided patch or upgraded to a later version of samba, cause this bug cause serious problems with CVS/SVN workong copies placed on a samba share.

Comment 1 Simo Sorce 2009-09-02 14:09:13 UTC
Samba 3.3.0 and Fedora 11 can use Extend Attributes to store DOS information.
Please avoid using map read only, and instead use store dos attributes.

Mapping dos attributes on permission bits have many side effects, so just use the work around described in the bug.
The patch is pushed upstream in the 3.3.X branch and will be available bundled with the next samba update.

Comment 2 260795 2009-09-02 15:04:44 UTC
Thanks. Unfortunately rebooting the server to enable the user_xattr on the mounted partitions is not an option for me. In the meantime I solved by rebuilding the SRC rpm and replacing the samba source tarball with a newer one, modifying the spec file where needed. Looking forward for the official update.

Comment 3 Simo Sorce 2009-09-02 15:21:01 UTC
Unless you kept upgrading from an anicent release of Fedora, both ACLs and xattrs are enabled by default on extX file systems.

Infact xattrs are needed also by Selinux.

Comment 4 260795 2009-09-02 15:35:26 UTC
You got it. This is a server which has been upgraded since RedHat 7.1 up to FC11. That's why xattrs are not enabled. Selinux disabled too. BTW, the interim upgrade solved the problem. The next time I'll reboot the server I'll take care to enable the latest extX features.

Thanks again for you quick support!


Note You need to log in before you can comment on or make changes to this bug.