Bug 520810 - Missing Dependency: /usr/bin/[ is needed by package
Summary: Missing Dependency: /usr/bin/[ is needed by package
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 14:00 UTC by Eric Paris
Modified: 2014-01-21 23:11 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-09-02 19:13:25 UTC


Attachments (Terms of Use)

Description Eric Paris 2009-09-02 14:00:16 UTC
Description of problem:

# yum update coreutils
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: coreutils = 7.5-2.fc12 for package: coreutils-libs-7.5-2.fc12.x86_64
---> Package coreutils.x86_64 0:7.5-3.fc12 set to be updated
--> Running transaction check
---> Package coreutils-libs.x86_64 0:7.5-3.fc12 set to be updated
--> Processing Dependency: /usr/bin/[ for package: redhat-lsb-3.2-5.fc12.x86_64
--> Finished Dependency Resolution
redhat-lsb-3.2-5.fc12.x86_64 from installed has depsolving problems
  --> Missing Dependency: /usr/bin/[ is needed by package redhat-lsb-3.2-5.fc12.x86_64 (installed)
Error: Missing Dependency: /usr/bin/[ is needed by package redhat-lsb-3.2-5.fc12.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

It looks like coreutils still provides it, but something is broken...

Comment 1 Eric Paris 2009-09-02 14:06:51 UTC
# rpm -q coreutils
coreutils-7.5-2.fc12.x86_64
# rpm -q yum
yum-3.2.23-15.fc12.noarch


Interesting note, looks like:

yumdownloader coreutils coreutils-libs
yum update *.rpm;

works just fine, so the rpms look ok, it's yum/the rawhide repo that is the problem....

Comment 2 Ondrej Vasik 2009-09-02 14:21:50 UTC
I tried update from coreutils-7.5-2 to coreutils-7.5-3 on my rawhide machine with
`yum update --enablerepo=koji --nogpgcheck coreutils` and it went just fine with no issues. So rpm-s seems to be ok.

koji repo base url : http://koji.fedoraproject.org/static-repos/dist-rawhide-current/x86_64/

Comment 3 seth vidal 2009-09-02 14:34:25 UTC
I think this is a yum bug introduced by a change I made in yum 3.2.23-15.

Comment 4 seth vidal 2009-09-02 14:59:35 UTC
I think this patch

http://skvidal.fedorapeople.org/misc/stupid-glob-bug.patch

fixes the problem - eparis if you can test it and report back, I'd appreciate it.

Comment 5 Eric Paris 2009-09-02 15:10:52 UTC
It worked for me.  I was able to update coreutils.

Comment 6 seth vidal 2009-09-02 19:13:25 UTC
http://kojipkgs.fedoraproject.org/packages/yum/3.2.23/16.fc12/noarch/yum-3.2.23-16.fc12.noarch.rpm

fixes this issue, though with a different patch.

Comment 7 Fedora Update System 2009-09-30 01:38:15 UTC
yum-3.2.24-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2009-10-19 16:45:04 UTC
yum-3.2.24-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-3.2.24-2.fc10

Comment 9 Fedora Update System 2009-11-04 12:05:21 UTC
yum-3.2.24-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.