Bug 520824 - No auth agent is started by default
Summary: No auth agent is started by default
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: polkit-gnome
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 15:07 UTC by Jiri Moskovcak
Modified: 2015-02-01 22:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-03 03:20:05 UTC


Attachments (Terms of Use)

Description Jiri Moskovcak 2009-09-02 15:07:57 UTC
Description of problem:
XFCE doesn't start any authorization agent.

Version-Release number of selected component (if applicable):
4.6.1-2

How reproducible:
I've installed rawhide without in minimal install (without any graphical environments) and later decided to $ yum groupinstall XFCE - and there was no auth agent running, so apps like PackageKit are not able to show the PolicyKit auth window. I had to manually run /usr/libexec/polkit-gnome-authentication-agent-1. Or is there any xfce-auth-manager that I forgot to install?

Actual results:
polkit auth window doesn't appear when user needs to escalate his privileges

Expected results:
Auth window appears when it's needed

Additional info:
Adding some auth agent to xfce autostart could fix (or workaround) this.

Comment 1 Kevin Fenzi 2009-09-02 16:43:45 UTC
This is due to /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop
having: 

OnlyShowIn=GNOME;KDE;

Possible fixes: 

1) Just add 'XFCE;' in there. 

2) Just remove the OnlyShowIn line entirely. Are there any other polkit agents that exist and are used currently? 

Moving over to polkit-gnome for comment...

Comment 2 Matthias Clasen 2009-09-03 03:20:05 UTC
I removed the line


Note You need to log in before you can comment on or make changes to this bug.