Bug 520907 - setroubleshoot: SELinux is preventing rtkit-daemon "write" access on anon_inode.
Summary: setroubleshoot: SELinux is preventing rtkit-daemon "write" access on ano...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:392deb4b375...
: 520909 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-02 19:53 UTC by Matěj Cepl
Modified: 2018-04-11 09:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-20 21:55:03 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2009-09-02 19:53:05 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing rtkit-daemon "write" access on anon_inode.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by rtkit-daemon. It is not expected that this
access is required by rtkit-daemon and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Další informace:

Kontext zdroje                system_u:system_r:initrc_t:s0-s0:c0.c1023
Kontext cíle                 system_u:object_r:anon_inodefs_t:s0
Objekty cíle                 anon_inode [ file ]
Zdroj                         rtkit-daemon
Cesta zdroje                  /usr/libexec/rtkit-daemon
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          rtkit-0.4-1.fc12
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.6.30-1.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-0.190.rc8.fc12.x86_64 #1 SMP
                              Fri Aug 28 18:51:58 EDT 2009 x86_64 x86_64
Počet upozornění           1
Poprvé viděno               St 2. září 2009, 21:51:49 CEST
Naposledy viděno             St 2. září 2009, 21:51:49 CEST
Místní ID                   36c21153-c530-48ba-84ad-6113881fae12
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1251921109.379:425): avc:  denied  { write } for  pid=2150 comm="rtkit-daemon" path="anon_inode:[eventfd]" dev=anon_inodefs ino=610 scontext=system_u:system_r:initrc_t:s0-s0:c0.c1023 tcontext=system_u:object_r:anon_inodefs_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1251921109.379:425): arch=c000003e syscall=1 success=yes exit=8 a0=6 a1=7f31362e0e58 a2=8 a3=4000 items=0 ppid=1 pid=2150 auid=4294967295 uid=486 gid=475 euid=486 suid=486 fsuid=486 egid=475 sgid=475 fsgid=475 tty=(none) ses=4294967295 comm="rtkit-daemon" exe="/usr/libexec/rtkit-daemon" subj=system_u:system_r:initrc_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t anon_inodefs_t:file write;

Comment 1 Daniel Walsh 2009-09-08 10:23:59 UTC
*** Bug 520909 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Walsh 2009-10-20 21:55:03 UTC
Fixed in selinux-policy-3.6.32-29.fc12.noarch


Note You need to log in before you can comment on or make changes to this bug.